Opened 8 years ago

Closed 6 years ago

Last modified 6 years ago

#453 closed defect (fixed)

I2P is launching ALL available browsers at startup

Reported by: i2pn00b Owned by: sponge
Priority: major Milestone: 0.9.3
Component: api/utils Version: 0.9.2
Keywords: console Cc: killyourtv@…
Parent Tickets:

Description

I've noticed this after upgrading to I2P-0.8.3. When starting I2P, it is launching ALL available browsers I've got installed.

Proof:

--- snip ---

     |-i2psvc-+-java-+-firefox---run-mozilla.sh---firefox-bin-+-plugin-containe---3*[{plugin-containe}]
     |        |      |                                        `-16*[{firefox-bin}]
     |        |      |-links
     |        |      |-lynx
     |        |      |-mozilla---run-mozilla.sh---seamonkey-bin---6*[{seamonkey-bin}]
     |        |      |-opera---4*[{opera}]
     |        |      `-142*[{java}]
     |        `-{i2psvc}

--- snip ---

This is the relevant snippet from the output of pstree on my linux system.

I'm sorry for such a long delay, it was due to the dreaded trac login bug.

Subtickets

Change History (13)

comment:1 Changed 8 years ago by zzz

OS? Distro?

comment:2 Changed 8 years ago by i2pn00b

Slackware 13.1 32-bit

$ java -version
java version "1.6.0_20"
Java(TM) SE Runtime Environment (build 1.6.0_20-b02)
Java HotSpot?(TM) Client VM (build 16.3-b01, mixed mode, sharing)

I ran pre-0.8.2 on the same system and didn't have this issue. Only one browser was started (opera).

comment:3 Changed 8 years ago by i2pn00b

Just to make things clear: problem appeared after upgrading to 0.8.3

Problem persisted after upgrading to 0.8.4

I still run 0.8.4 now

comment:4 Changed 8 years ago by i2pn00b

I2P updated to 0.8.5

Problem persists.

comment:5 Changed 8 years ago by i2pn00b

I think I've just excluded one more factor from the problem. When a stable I2P version is released, I wipe the i2p directory and install the new version from scratch. But I keep the ~/.i2p directory that contains user settings. I've tried to delete this directory as well, so I2P-0.8.5 would create a default ~/.i2p directory during its first startup. Still getting all the browsers launched. I guess this means it doesn't happen because of an eventual interference caused by an user specific config file for an older I2P version.

comment:6 Changed 8 years ago by zzz

  • Milestone changed from 0.8.5 to 0.8.7
  • Owner set to sponge
  • Status changed from new to assigned

sponge's friend saw this on slackware. Sponge thinks it may be caused by a 128 return value from fork. Assigning to him since he has both a theory and a way to reproduce it. See ShellCommand?.java near the bottom.

comment:7 Changed 8 years ago by killyourtv

  • Milestone changed from 0.8.7 to 0.8.9

comment:8 Changed 7 years ago by str4d

  • Milestone changed from 0.8.12 to 0.8.14

comment:9 Changed 7 years ago by zzz

  • Milestone 0.8.14 deleted

Milestone 0.8.14 deleted

comment:10 Changed 6 years ago by killyourtv

  • Cc killyourtv@… added
  • Milestone set to 0.9.4
  • Version changed from 0.8.3 to 0.9.2

While working on #711, I was able to reproduce this with 0.9.2-13 on one of my testing systems.

java version "1.7.0_07"
OpenJDK Runtime Environment (IcedTea7 2.3.2) (ArchLinux build 7.u7_2.3.2-2-i686)
OpenJDK Client VM (build 23.2-b09, mixed mode)
i2p.service - I2P Service
          Loaded: loaded (/etc/systemd/system/i2p.service; disabled)
          Active: active (running) since Wed, 10 Oct 2012 08:55:40 +0000; 6min ago 
         Process: 698 ExecStart=/home/user/i2p/i2prouter start (code=exited, status=0/SUCCESS)
        Main PID: 813 (i2psvc)
          CGroup: name=systemd:/system/i2p.service
                  ├  813 /home/user/i2p/i2psvc /home/user/i2p/wrapper.config wrapper.syslog.ident=i2p wrapper.java.command=java wrapper.pidfile=/home/user/.i2p/i2p.pid wrapper.name=i2p wrapper.displayname=I2P Servi...
                  ├  815 /usr/lib/jvm/java-7-openjdk/jre/bin/java -DloggerFilenameOverride=logs/log-router-@.txt -Dorg.mortbay.http.Version.paranoid=true -Dorg.mortbay.xml.XmlParser.NotValidating=true -Di2p.dir.base=/home/user/...
                  ├  947 /bin/sh /usr/bin/xdg-open http://127.0.0.1:7657/
                  ├ 1066 links http://127.0.0.1:7657/
                  ├ 1074 lynx http://127.0.0.1:7657/
                  └ 1094 lynx http //127.0.0.1 7657/

I'll try to reproduce this with other versions.

comment:11 Changed 6 years ago by killyourtv

Update: I can also reproduce this on Archlinux with 0.8.3. I cannot reproduce this with 0.8.2.

comment:12 Changed 6 years ago by zzz

  • Milestone changed from 0.9.4 to 0.9.3
  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in 0.9.2-14

comment:13 Changed 6 years ago by zzz

  • Component changed from apps/console to api/utils
Note: See TracTickets for help on using tickets.