Opened 9 years ago

Closed 7 years ago

#461 closed defect (fixed)

Syndie's welcome screen is unintentionally (overly) wide

Reported by: killyourtv Owned by:
Priority: minor Milestone:
Component: apps/syndie Version:
Keywords: syndie, swt Cc: killyourtv@…
Parent Tickets: Sensitive: no

Description

This is a problem in both the plugin and my self-compiled Debian package. The only half of the window is visible at a time.

I was able to reproduce this on two different systems using swt 3.5 and Java version: Sun Microsystems Inc. 1.6.0_18 (OpenJDK Runtime Environment 1.6.0_18-b18). One system has an Nvidia card (using the proprietary binary driver) and the other with an ATI card, using the Radeon driver included with Xorg.

(While I realize that Syndie is in need of a maintainer, I still wanted to document this weirdness with the welcome screen. Perhaps if the author of this post is still around, he would know how to resolve the issue (since he seemingly implemented the welcome screen)).

I'm sorry if this isn't the proper place to report this…

Subtickets

Attachments (2)

syndie-welcome.png (11.5 KB) - added by killyourtv 9 years ago.
Very large welcome screen for Syndie
normal-welcome.png (54.9 KB) - added by killyourtv 7 years ago.
Syndie's welcome screen with x64 swt.jar in Win7

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by killyourtv

Attachment: syndie-welcome.png added

Very large welcome screen for Syndie

comment:1 Changed 9 years ago by zzz

Component: apps/pluginsapps/syndie

comment:2 Changed 9 years ago by killyourtv

Was apps/syndie in the component dropdown? I /really/ didn't see it. :s

Anyhow, in case anyone stumbles upon this before it's fixed: SPACE SPACE SPACE SPACE TAB TAB SPACE will get you through with sane defaults.

Changed 7 years ago by killyourtv

Attachment: normal-welcome.png added

Syndie's welcome screen with x64 swt.jar in Win7

comment:3 Changed 7 years ago by killyourtv

Interestingly, the Syndie that I built with the x64 swt.jar for Windows 7 looks normal.

comment:4 Changed 7 years ago by zzz

Reproduced here with org.eclipse.swt_3.7.2.jar.

The welcome screen only appears on first run, i.e. when the ~/.syndie dir does not exist. To reproduce the bug, mv ~/.syndie ~/.syndie-save

For the plugin, it's ~/.i2p/plugins/syndie/.syndie

comment:5 Changed 7 years ago by zzz

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.