Opened 8 years ago

Closed 8 years ago

#479 closed defect (fixed)

i2p snark error info more and more

Reported by: DISABLED Owned by: zzz
Priority: minor Milestone: 0.8.8
Component: apps/console Version: 0.8.6
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

I2P version: 0.8.6-0
Java version: Sun Microsystems Inc. 1.6.0_24 (Java™ SE Runtime Environment 1.6.0_24-b07)
Platform: Windows XP x86 5.1
Processor: Core 2 (Conroe) (pentium4)
Jbigi: Locally optimized native BigInteger? library loaded from the library path
Encoding: Cp1252

FEHLER [soleSocket-0] p.router.web.jsp.viewtheme_jsp: Error serving /themes/snark/ubergine/images/snarknav_lowlight.png

EOFException(EOFException(java.net.SocketException?: Connection reset by peer: socket write error))
at org.mortbay.http.BufferedOutputStream?.flush(BufferedOutputStream?.java:209)
at org.mortbay.http.HttpOutputStream?.flush(HttpOutputStream?.java:478)
at org.mortbay.http.HttpOutputStream?.write(HttpOutputStream?.java:425)
at org.mortbay.jetty.servlet.ServletOut?.write(ServletOut?.java:54)
at net.i2p.util.FileUtil?.readFile(FileUtil?.java:381)
at net.i2p.router.web.jsp.viewtheme_jsp._jspService(viewtheme_jsp.java:105)
at org.apache.jasper.runtime.HttpJspBase?.service(HttpJspBase?.java:94)
at javax.servlet.http.HttpServlet?.service(HttpServlet?.java:689)
at org.mortbay.jetty.servlet.ServletHolder?.handle(ServletHolder?.java:428)
at org.mortbay.jetty.servlet.WebApplicationHandler?.dispatch(WebApplicationHandler?.java:473)
at org.mortbay.jetty.servlet.ServletHandler?.handle(ServletHandler?.java:568)
at net.i2p.router.web.LocaleWebAppHandler?.handle(LocaleWebAppHandler?.java:90)
at org.mortbay.http.HttpContext?.handle(HttpContext?.java:1535)
at org.mortbay.jetty.servlet.WebApplicationContext?.handle(WebApplicationContext?.java:633)
at org.mortbay.http.HttpContext?.handle(HttpContext?.java:1487)
at org.mortbay.http.HttpServer?.service(HttpServer?.java:909)
at org.mortbay.http.HttpConnection?.service(HttpConnection?.java:820)
at org.mortbay.http.HttpConnection?.handleNext(HttpConnection?.java:986)
at org.mortbay.http.HttpConnection?.handle(HttpConnection?.java:837)
at org.mortbay.http.SocketListener?.handleConnection(SocketListener?.java:245)
at org.mortbay.util.ThreadedServer?.handle(ThreadedServer?.java:357)
at org.mortbay.util.ThreadPool?$PoolThread?.run(ThreadPool?.java:534)

15:54:52.070 FEHLER [soleSocket-4] p.router.web.jsp.viewtheme_jsp: Error serving /themes/console/classic/console.css

EOFException(java.net.SocketException?: Connection reset by peer: socket write error)
at org.mortbay.http.BufferedOutputStream?.flush(BufferedOutputStream?.java:209)
at org.mortbay.util.ByteBufferOutputStream?.ensureSpareCapacity(ByteBufferOutputStream?.java:371)
at org.mortbay.util.ByteBufferOutputStream?.write(ByteBufferOutputStream?.java:197)
at org.mortbay.http.BufferedOutputStream?.write(BufferedOutputStream?.java:149)
at org.mortbay.http.HttpOutputStream?.write(HttpOutputStream?.java:423)
at org.mortbay.jetty.servlet.ServletOut?.write(ServletOut?.java:54)
at net.i2p.util.FileUtil?.readFile(FileUtil?.java:381)
at net.i2p.router.web.jsp.viewtheme_jsp._jspService(viewtheme_jsp.java:105)
at org.apache.jasper.runtime.HttpJspBase?.service(HttpJspBase?.java:94)
at javax.servlet.http.HttpServlet?.service(HttpServlet?.java:689)
at org.mortbay.jetty.servlet.ServletHolder?.handle(ServletHolder?.java:428)
at org.mortbay.jetty.servlet.WebApplicationHandler?.dispatch(WebApplicationHandler?.java:473)
at org.mortbay.jetty.servlet.ServletHandler?.handle(ServletHandler?.java:568)
at net.i2p.router.web.LocaleWebAppHandler?.handle(LocaleWebAppHandler?.java:90)
at org.mortbay.http.HttpContext?.handle(HttpContext?.java:1535)
at org.mortbay.jetty.servlet.WebApplicationContext?.handle(WebApplicationContext?.java:633)
at org.mortbay.http.HttpContext?.handle(HttpContext?.java:1487)
at org.mortbay.http.HttpServer?.service(HttpServer?.java:909)
at org.mortbay.http.HttpConnection?.service(HttpConnection?.java:820)
at org.mortbay.http.HttpConnection?.handleNext(HttpConnection?.java:986)
at org.mortbay.http.HttpConnection?.handle(HttpConnection?.java:837)
at org.mortbay.http.SocketListener?.handleConnection(SocketListener?.java:245)
at org.mortbay.util.ThreadedServer?.handle(ThreadedServer?.java:357)
at org.mortbay.util.ThreadPool?$PoolThread?.run(ThreadPool?.java:534)

12:58:30.680 FEHLER [soleSocket-6] p.router.web.jsp.viewtheme_jsp: Error serving /themes/snark/ubergine/images/snarknav_lowlight.png

EOFException(EOFException(java.net.SocketException?: Connection reset by peer: socket write error))
at org.mortbay.http.BufferedOutputStream?.flush(BufferedOutputStream?.java:209)
at org.mortbay.http.HttpOutputStream?.flush(HttpOutputStream?.java:478)
at org.mortbay.http.HttpOutputStream?.write(HttpOutputStream?.java:425)
at org.mortbay.jetty.servlet.ServletOut?.write(ServletOut?.java:54)
at net.i2p.util.FileUtil?.readFile(FileUtil?.java:381)
at net.i2p.router.web.jsp.viewtheme_jsp._jspService(viewtheme_jsp.java:105)
at org.apache.jasper.runtime.HttpJspBase?.service(HttpJspBase?.java:94)
at javax.servlet.http.HttpServlet?.service(HttpServlet?.java:689)
at org.mortbay.jetty.servlet.ServletHolder?.handle(ServletHolder?.java:428)
at org.mortbay.jetty.servlet.WebApplicationHandler?.dispatch(WebApplicationHandler?.java:473)
at org.mortbay.jetty.servlet.ServletHandler?.handle(ServletHandler?.java:568)
at net.i2p.router.web.LocaleWebAppHandler?.handle(LocaleWebAppHandler?.java:90)
at org.mortbay.http.HttpContext?.handle(HttpContext?.java:1535)
at org.mortbay.jetty.servlet.WebApplicationContext?.handle(WebApplicationContext?.java:633)
at org.mortbay.http.HttpContext?.handle(HttpContext?.java:1487)
at org.mortbay.http.HttpServer?.service(HttpServer?.java:909)
at org.mortbay.http.HttpConnection?.service(HttpConnection?.java:820)
at org.mortbay.http.HttpConnection?.handleNext(HttpConnection?.java:986)
at org.mortbay.http.HttpConnection?.handle(HttpConnection?.java:837)
at org.mortbay.http.SocketListener?.handleConnection(SocketListener?.java:245)
at org.mortbay.util.ThreadedServer?.handle(ThreadedServer?.java:357)
at org.mortbay.util.ThreadPool?$PoolThread?.run(ThreadPool?.java:534)

Subtickets

Change History (4)

comment:1 Changed 8 years ago by killyourtv

Component: unspecifiedapps/i2psnark
Owner: set to zzz

Duplicate of #477, but since there's more information here I'll close the other one.

comment:2 Changed 8 years ago by zzz

Milestone: 0.8.70.8.8
Priority: majorminor
Status: newassigned

I don't have a good idea what could cause this. Perhaps the browser is leaving the page while it is loading, and the sockets are being closed while viewtheme.jsp is writing the data.

If so, it should just be changed to a warning so nobody sees it.

Do you see any problems on the i2psnark screen, or are the router logs the only indication of a problem?

comment:3 Changed 8 years ago by zzz

Component: apps/i2psnarkapps/console

ok, that's a new error I put in for 0.8.6, should have been a warning, I'll change it.

comment:4 Changed 8 years ago by zzz

Resolution: fixed
Status: assignedclosed

Changed to warn in 0.8.7-2

Note: See TracTickets for help on using tickets.