Opened 8 years ago

Closed 8 years ago

#480 closed defect (fixed)

Selecting Persistent Private Keys doesn't work with an existing tunnel

Reported by: killyourtv Owned by: zzz
Priority: minor Milestone: 0.8.9
Component: apps/i2ptunnel Version: 0.8.6
Keywords: persistent keys, i2ptunnel Cc: killyourtv@…
Parent Tickets: Sensitive: no

Description

Specs:

I2P version: 0.8.6-31-rc-deb1
Java version: Sun Microsystems Inc. 1.6.0_18 (OpenJDK Runtime Environment 1.6.0_18-b18)
Platform: Linux amd64 2.6.39-2-amd64
Processor: Athlon 64 FX (Sledgehammer S939, 130 nm) (athlon64)
Jbigi: Locally optimized native BigInteger library loaded from file
Encoding: ANSI_X3.4-1968

I tried to change an already existing IRC tunnel (to welterde) to use Persistent Private Keys.

I can reproduce with the following steps:
1) Stop an already existing tunnel.
2) configure the tunnel to use persistent keys
3) hit save
4) try to start the tunnel
5) See error at the top of http://localhost:7657/i2ptunnel/ (reproduced below)

Starting tunnel welterde…
Error opening key file java.io.FileNotFoundException: /var/lib/i2p/i2p-config/i2ptunnel21-privKeys.dat (No such file or directory)
Invalid I2PTunnel configuration to create an IRC client connecting to the router at 127.0.0.1:7654 and listening on 127.0.0.1:7654
Error starting the tunnel welterde: Error opening key file java.io.FileNotFoundException: /var/lib/i2p/i2p-config/i2ptunnel21-privKeys.dat (No such file or directory)

It seems that the key is only created if persistent keys are enabled at the time of tunnel creation as removing the tunnel and recreating it worked fine.

Subtickets

Change History (2)

comment:1 Changed 8 years ago by zzz

Milestone: 0.8.80.8.10
Owner: set to zzz
Priority: majorminor
Status: newassigned

yeah, that sounds right. Both the tunnel's identity and the destination's identity have to be set at startup. That's why b32 targets don't work well.

comment:2 Changed 8 years ago by zzz

Milestone: 0.8.100.8.9
Resolution: fixed
Status: assignedclosed

Fixed in 0.8.8-12, please test.

Note: See TracTickets for help on using tickets.