Opened 8 years ago

Closed 3 years ago

#481 closed defect (fixed)

UPnP: [Fatal Error] :15:1: Content is not allowed in trailing section.

Reported by: guest Owned by:
Priority: minor Milestone: 0.9.22
Component: router/transport Version: 0.8.7
Keywords: UPnP Cc:
Parent Tickets:

Description

Hi,

Since the new upgrade to 0.8.7 yesterday, i get a Fatal error.

2011/06/28 02:06:02 | INFO: Started org.mortbay.jetty.Server@679bfb30
2011/06/28 02:06:02 | [Fatal Error] :15:1: Content is not allowed in trailing section.
2011/06/28 02:06:03 | [Fatal Error] :6:1: Content is not allowed in trailing section.
2011/06/28 02:06:03 | [Fatal Error] :6:1: Content is not allowed in trailing section.
2011/06/28 02:06:03 | [Fatal Error] :6:1: Content is not allowed in trailing section.
2011/06/28 02:06:03 | [Fatal Error] :6:1: Content is not allowed in trailing section.

I2P version: 0.8.7-0deb2

Java version: Sun Microsystems Inc. 1.6.0_20 (OpenJDK Runtime Environment 1.6.0_20-b20)
Platform: Linux amd64 2.6.38-10-generic
Processor: uninitialized (core2)
Jbigi: Locally optimized native BigInteger? library loaded from file
Encoding: UTF-8

Best Regards

Subtickets

#1653: SAXParserException 'Content not allowed in trailing section'defectclosedzzz

Change History (13)

comment:1 Changed 8 years ago by guest

  • Component changed from package/ubuntu to wrapper

comment:2 Changed 8 years ago by killyourtv

  • Component changed from wrapper to router/general
  • Keywords upnp added

From IRC:

<ThePriest?> jvm 1 | [Fatal Error] :6:1: Content is not allowed in trailing section.
<ThePriest?> jvm 1 | [Fatal Error] :6:1: Content is not allowed in trailing section.
<ThePriest?> jvm 1 | [Fatal Error] :6:1: Content is not allowed in trailing section.
<ThePriest?> jvm 1 | [Fatal Error] :6:1: Content is not allowed in trailing section.
<ThePriest?> jvm 1 | [Fatal Error] :6:1: Content is not allowed in trailing section.
<ThePriest?> jvm 1 | [Fatal Error] :6:1: Content is not allowed in trailing section.
<ThePriest?> is this bad???
<zzz> no
<zzz> it's a UPnP error I've tried to fix, guess I wasn't 100% successful :(

comment:3 Changed 8 years ago by killyourtv

  • Owner killyourtv deleted
  • Status changed from new to assigned

comment:4 Changed 8 years ago by zzz

  • Component changed from router/general to router/transport
  • Priority changed from major to minor

The attempted fix was in 0.8.6. I don't think that anything in 0.8.7 made it any worse. The problem is certain UPnP routers returning bad XML. You can ignore the error or turn off UPnP or switch routers.

comment:5 Changed 8 years ago by guest

Hi zzz,

Thanks for your answer, i have turn off my upnp, i don't need it anyway.

Best regards

comment:6 Changed 7 years ago by str4d

  • Milestone changed from 0.8.12 to 0.8.14

comment:7 Changed 7 years ago by guest

  • Keywords Fatal Error 15:1 added; upnp removed
  • Summary changed from [Fatal Error] :15:1: Content is not allowed in trailing section. to Problem Remains in 0.9.0 - [Fatal Error] :15:1: Content is not allowed in trailing section.
  • Version changed from 0.8.7 to 0.9

Dear i2p Developers:

Just an update on this same issue from a different user (on Windows 7). I have experienced this same error since the earliest 0.8.* versions. I have upgraded continuously as new builds were released. This error has been persisent since then. I am now on 0.9.0 and this error remains.

However, everything within i2p appears to be working properly.

comment:8 Changed 7 years ago by guest

  • Summary changed from Problem Remains in 0.9.0 - [Fatal Error] :15:1: Content is not allowed in trailing section. to Problem Resolved - [Fatal Error] :15:1: Content is not allowed in trailing section.

Update: issue is resolved under Windows by disabling UPnP.

comment:9 Changed 7 years ago by zzz

  • Keywords UPnP added; Fatal Error 15:1 removed
  • Milestone changed from 0.8.14 to 0.9.3
  • Summary changed from Problem Resolved - [Fatal Error] :15:1: Content is not allowed in trailing section. to UPnP: [Fatal Error] :15:1: Content is not allowed in trailing section.
  • Version changed from 0.9 to 0.8.7

That's a workaround, not a fix. Changing the title back. As explained above, it's caused by UPnP devices generating bad XML, but our parser should be able to handle it.

I am working on upgrading our UPnP library but I don't think that will fix it either.

comment:10 Changed 6 years ago by str4d

  • Milestone 0.9.3 deleted

comment:11 Changed 4 years ago by zzz

UPnP lib updated to latest in 0.9.18-6, but unlikely to fix this. We should proceed with a local fix if possible.

comment:12 Changed 3 years ago by zzz

Add a subticket #1653.

comment:13 Changed 3 years ago by zzz

  • Milestone set to 0.9.22
  • Resolution set to fixed
  • Status changed from assigned to closed

See #1653 for resolution

Note: See TracTickets for help on using tickets.