Opened 8 years ago

Closed 15 months ago

#491 closed defect (no response)

Not working i2p (I2CP port conflict?)

Reported by: guest Owned by:
Priority: minor Milestone:
Component: api/i2cp Version: 0.8.7
Keywords: Cc:
Parent Tickets:

Description

I2P version: 0.8.7-0
Java version: Sun Microsystems Inc. 1.6.0_26 (Java(TM) SE Runtime Environment 1.6.0_26-b03)
Platform: Windows XP x86 5.1
Processor: Core 2 (Conroe) (core2)
Jbigi: Locally optimized native BigInteger? library loaded from file

CRIT [istener:7654] er.client.ClientListenerRunner?: I2CP error listening to port 7654 - is another I2P instance running? Resolve conflicts and restart

Subtickets

Change History (6)

comment:1 Changed 8 years ago by killyourtv

1) Is there another copy of I2P running? (does the Router Console load?)
2) Is there something already running on that port? (You can check at a command prompt)

-- Start -> run enter "cmd" then press [enter]
-- type netstat -an |find "7654" [enter]

You could try rebooting and seeing if I2P will start after a reboot. If it does, cool, something else was on that port. If not, we can change the port I2P uses.


Every time that this error has come up in the past the cause has been another instance of I2P running. If that's not the case this time (and something else really is using that port) it can be changed in I2P or the other software that's conflicting with I2P...

comment:2 Changed 8 years ago by killyourtv

  • Priority changed from major to minor

comment:3 Changed 8 years ago by zzz

  • Component changed from unspecified to api/i2cp
  • Milestone changed from 0.8.8 to 0.9
  • Summary changed from Not working i2p to Not working i2p (I2CP port conflict?)

since in-JVM clients now connect to the I2CP client manager internally rather than via the I2CP socket on port 7654, this error isn't fatal any more, perhaps we should tweak the error message?

comment:4 Changed 7 years ago by zzz

  • Milestone changed from 0.9 to 0.9.4

#731 is related

comment:5 Changed 6 years ago by str4d

  • Milestone 0.9.4 deleted

comment:6 Changed 15 months ago by echelon

  • Resolution set to no response
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.