Opened 8 years ago

Closed 8 years ago

#496 closed defect (fixed)

Seedless: Remove dependency on net.i2p.i2ptunnel.web

Reported by: zzz Owned by: sponge
Priority: major Milestone: 0.8.9
Component: apps/plugins Version: 0.8.7
Keywords: Cc:
Parent Tickets:

Description

In Feb. 2010 seedless started using classes in net.i2p.i2ptunnel.web which are in i2ptunnel.jar. At the time I advised that that was a bad idea as those classes are used only by the webapp and were due to be moved to i2ptunnel.war.

In July 2010 I added the following note to the classes:

 * Warning - This class is not part of the i2ptunnel API, and at some point
 * it will be moved from the jar to the war.
 * Usage by classes outside of i2ptunnel.war is deprecated.

I would now like to move the classes to the war for the reasons stated above and because they are increasing the size of the Android app unnecessarily.

Please remove the dependency and release a new plugin version. Thanks.

Subtickets

Change History (2)

comment:1 Changed 8 years ago by zzz

  • Priority changed from minor to major

Edit: I see that you are actually instaniating EditBean?, not just using static methods! This is a big problem as it may be the cause of the continuing i2ptunnel nonce issues. Every time it's instantiated the nonces get shifted.

If there are small utility functions that you need from EditBean? / IndexBean?, perhaps you can move them to a net.i2p.i2ptunnel utility class.

comment:2 Changed 8 years ago by sponge

  • Resolution set to fixed
  • Status changed from new to closed

Done.

Note: See TracTickets for help on using tickets.