Opened 8 years ago

Closed 8 years ago

#506 closed defect (fixed)

Systray failure with a 64bit jvm in Windows

Reported by: killyourtv Owned by: killyourtv
Priority: major Milestone: 0.8.8
Component: apps/console Version: 0.8.7
Keywords: Cc: killyourtv
Parent Tickets: Sensitive: no

Description

2011/08/17 xx:xx:35 | --> Wrapper Started as Console
2011/08/17 xx:xx:35 | Java Service Wrapper Community Edition 64-bit 3.5.9
2011/08/17 xx:xx:35 |   Copyright (C) 1999-2011 Tanuki Software, Ltd. All Rights Reserved.
2011/08/17 xx:xx:35 |     http://wrapper.tanukisoftware.com
2011/08/17 xx:xx:35 | 
2011/08/17 xx:xx:36 | Launching a JVM...
2011/08/17 xx:xx:36 | WrapperManager: Initializing...
2011/08/17 xx:xx:37 | Starting I2P 0.8.7-0
2011/08/17 xx:xx:37 | INFO: Native CPUID library jcpuid-x86-windows loaded from file
2011/08/17 xx:xx:37 | INFO: Locally optimized native BigInteger library loaded from file
2011/08/17 xx:xx:38 | systray4j: C:\Program Files\i2p\lib\systray4j.dll: Can't find dependent libraries
2011/08/17 xx:xx:38 | java.lang.ExceptionInInitializerError
2011/08/17 xx:xx:38 | 	at net.i2p.router.web.RouterConsoleRunner.startTrayApp(RouterConsoleRunner.java:153)
2011/08/17 xx:xx:38 | 	at net.i2p.router.web.RouterConsoleRunner.main(RouterConsoleRunner.java:132)
2011/08/17 xx:xx:38 | 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
2011/08/17 xx:xx:38 | 	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
2011/08/17 xx:xx:38 | 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
2011/08/17 xx:xx:38 | 	at java.lang.reflect.Method.invoke(Unknown Source)
2011/08/17 xx:xx:38 | 	at net.i2p.router.startup.LoadClientAppsJob$RunApp.run(LoadClientAppsJob.java:238)
2011/08/17 xx:xx:38 | 	at java.lang.Thread.run(Unknown Source)
2011/08/17 xx:xx:38 | 	at net.i2p.util.I2PThread.run(I2PThread.java:77)
2011/08/17 xx:xx:38 | Caused by: java.awt.HeadlessException
2011/08/17 xx:xx:38 | 	at java.awt.GraphicsEnvironment.checkHeadless(Unknown Source)
2011/08/17 xx:xx:38 | 	at java.awt.Window.<init>(Unknown Source)
2011/08/17 xx:xx:38 | 	at java.awt.Frame.<init>(Unknown Source)
2011/08/17 xx:xx:38 | 	at java.awt.Frame.<init>(Unknown Source)
2011/08/17 xx:xx:38 | 	at javax.swing.JFrame.<init>(Unknown Source)
2011/08/17 xx:xx:38 | 	at snoozesoft.systray4j.NotAvailable.<init>(NotAvailable.java:64)
2011/08/17 xx:xx:38 | 	at snoozesoft.systray4j.SysTrayManager.addMainMenu(SysTrayManager.java:64)
2011/08/17 xx:xx:38 | 	at snoozesoft.systray4j.SysTrayMenu.<init>(SysTrayMenu.java:123)
2011/08/17 xx:xx:38 | 	at snoozesoft.systray4j.SysTrayMenu.<init>(SysTrayMenu.java:93)
2011/08/17 xx:xx:38 | 	at net.i2p.apps.systray.SysTray.<init>(SysTray.java:63)
2011/08/17 xx:xx:38 | 	at net.i2p.apps.systray.SysTray.<clinit>(SysTray.java:56)
2011/08/17 xx:xx:38 | 	... 9 more

Subtickets

Change History (1)

comment:1 Changed 8 years ago by killyourtv

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.