Opened 8 years ago

Closed 7 years ago

#512 closed defect (fixed)

I did it (...with I2PBote)

Reported by: killyourtv Owned by: HungryHobo
Priority: minor Milestone: 0.8.12
Component: apps/plugins Version: 0.8.7
Keywords: i2pbote, I2PAppContext, "I did it" Cc:
Parent Tickets:

Description

An old(ish) and known problem but I don't think has been documented in an official manner.


I2P version: 0.8.7-27-rc-deb1
Java version: Sun Microsystems Inc. 1.6.0_23 (OpenJDK Runtime Environment 1.6.0_23-b23)
Platform: Linux amd64 3.0.0-1-amd64
Processor: Athlon 64 FX (Sledgehammer S939, 130 nm) (athlon64)
Jbigi: Locally optimized native BigInteger? library loaded from file
Encoding: UTF-8

Starting I2PBote caused the following entries to be logged.

2011/08/22 10:30:37 | Warning - New context not replacing old one, you now have a second one
2011/08/22 10:30:37 | java.lang.Exception: I did it
2011/08/22 10:30:37 |   at net.i2p.I2PAppContext.<init>(I2PAppContext.java:194)
2011/08/22 10:30:37 |   at net.i2p.I2PAppContext.<init>(I2PAppContext.java:163)
2011/08/22 10:30:37 |   at i2p.bote.crypto.ECDH_ECDSA.<init>(ECDH_ECDSA.java:116)
2011/08/22 10:30:37 |   at i2p.bote.crypto.ECDH256_ECDSA256.<init>(ECDH256_ECDSA256.java:44)
2011/08/22 10:30:37 |   at i2p.bote.crypto.CryptoFactory.init(CryptoFactory.java:54)
2011/08/22 10:30:37 |   at i2p.bote.crypto.CryptoFactory.getInstances(CryptoFactory.java:45)
2011/08/22 10:30:37 |   at i2p.bote.email.EmailDestination.extractBase64Dest(EmailDestination.java:102)
2011/08/22 10:30:37 |   at i2p.bote.email.AddressDisplayFilter.getNameAndDestination(AddressDisplayFilter.java:59)
2011/08/22 10:30:37 |   at i2p.bote.web.JSPHelper.getNameAndDestination(JSPHelper.java:520)
2011/08/22 10:30:37 |   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
2011/08/22 10:30:37 |   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
2011/08/22 10:30:37 |   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
2011/08/22 10:30:37 |   at java.lang.reflect.Method.invoke(Method.java:616)
2011/08/22 10:30:37 |   at org.apache.commons.el.FunctionInvocation.evaluate(FunctionInvocation.java:172)
2011/08/22 10:30:37 |   at org.apache.commons.el.ExpressionEvaluatorImpl.evaluate(ExpressionEvaluatorImpl.java:263)
2011/08/22 10:30:37 |   at org.apache.commons.el.ExpressionEvaluatorImpl.evaluate(ExpressionEvaluatorImpl.java:190)
2011/08/22 10:30:37 |   at org.apache.jasper.runtime.PageContextImpl.proprietaryEvaluate(PageContextImpl.java:899)
2011/08/22 10:30:37 |   at i2p.bote.jsp.folder_jsp._jspx_meth_c_set_30(folder_jsp.java:1577)
2011/08/22 10:30:37 |   at i2p.bote.jsp.folder_jsp._jspx_meth_c_forEach_0(folder_jsp.java:1459)
2011/08/22 10:30:37 |   at i2p.bote.jsp.folder_jsp._jspx_meth_ib_requirePassword_0(folder_jsp.java:313)
2011/08/22 10:30:37 |   at i2p.bote.jsp.folder_jsp._jspService(folder_jsp.java:124)
2011/08/22 10:30:37 |   at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:94)
2011/08/22 10:30:37 |   at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
2011/08/22 10:30:37 |   at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:428)
2011/08/22 10:30:37 |   at org.mortbay.jetty.servlet.WebApplicationHandler.dispatch(WebApplicationHandler.java:473)
2011/08/22 10:30:37 |   at org.mortbay.jetty.servlet.Dispatcher.dispatch(Dispatcher.java:286)
2011/08/22 10:30:37 |   at org.mortbay.jetty.servlet.Dispatcher.forward(Dispatcher.java:171)
2011/08/22 10:30:37 |   at org.apache.jasper.runtime.PageContextImpl.doForward(PageContextImpl.java:670)
2011/08/22 10:30:37 |   at org.apache.jasper.runtime.PageContextImpl.forward(PageContextImpl.java:637)
2011/08/22 10:30:37 |   at i2p.bote.jsp.index_jsp._jspService(index_jsp.java:44)
2011/08/22 10:30:37 |   at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:94)
2011/08/22 10:30:37 |   at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
2011/08/22 10:30:37 |   at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:428)
2011/08/22 10:30:37 |   at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplicationHandler.java:830)
2011/08/22 10:30:37 |   at i2p.bote.web.CharsetFilter.doFilter(CharsetFilter.java:38)
2011/08/22 10:30:37 |   at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplicationHandler.java:821)
2011/08/22 10:30:37 |   at org.mortbay.jetty.servlet.WebApplicationHandler.dispatch(WebApplicationHandler.java:471)
2011/08/22 10:30:37 |   at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:568)
2011/08/22 10:30:37 |   at org.mortbay.http.HttpContext.handle(HttpContext.java:1535)
2011/08/22 10:30:37 |   at org.mortbay.jetty.servlet.WebApplicationContext.handle(WebApplicationContext.java:633)
2011/08/22 10:30:37 |   at org.mortbay.http.HttpContext.handle(HttpContext.java:1487)
2011/08/22 10:30:37 |   at org.mortbay.http.HttpServer.service(HttpServer.java:909)
2011/08/22 10:30:37 |   at org.mortbay.http.HttpConnection.service(HttpConnection.java:820)
2011/08/22 10:30:37 |   at org.mortbay.http.HttpConnection.handleNext(HttpConnection.java:986)
2011/08/22 10:30:37 |   at org.mortbay.http.HttpConnection.handle(HttpConnection.java:837)
2011/08/22 10:30:37 |   at org.mortbay.http.SocketListener.handleConnection(SocketListener.java:245)
2011/08/22 10:30:37 |   at org.mortbay.util.ThreadedServer.handle(ThreadedServer.java:357)
2011/08/22 10:30:37 |   at org.mortbay.util.ThreadPool$PoolThread.run(ThreadPool.java:534)
2011/08/22 10:30:37 | Warning - New context not replacing old one, you now have a second one
2011/08/22 10:30:37 | java.lang.Exception: I did it
2011/08/22 10:30:37 |   at net.i2p.I2PAppContext.<init>(I2PAppContext.java:194)
2011/08/22 10:30:37 |   at net.i2p.I2PAppContext.<init>(I2PAppContext.java:163)
2011/08/22 10:30:37 |   at i2p.bote.crypto.ECDH_ECDSA.<init>(ECDH_ECDSA.java:116)
2011/08/22 10:30:37 |   at i2p.bote.crypto.ECDH521_ECDSA521.<init>(ECDH521_ECDSA521.java:49)
2011/08/22 10:30:37 |   at i2p.bote.crypto.CryptoFactory.init(CryptoFactory.java:55)
2011/08/22 10:30:37 |   at i2p.bote.crypto.CryptoFactory.getInstances(CryptoFactory.java:45)
2011/08/22 10:30:37 |   at i2p.bote.email.EmailDestination.extractBase64Dest(EmailDestination.java:102)
2011/08/22 10:30:37 |   at i2p.bote.email.AddressDisplayFilter.getNameAndDestination(AddressDisplayFilter.java:59)
2011/08/22 10:30:37 |   at i2p.bote.web.JSPHelper.getNameAndDestination(JSPHelper.java:520)
2011/08/22 10:30:37 |   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
2011/08/22 10:30:37 |   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
2011/08/22 10:30:37 |   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
2011/08/22 10:30:37 |   at java.lang.reflect.Method.invoke(Method.java:616)
2011/08/22 10:30:37 |   at org.apache.commons.el.FunctionInvocation.evaluate(FunctionInvocation.java:172)
2011/08/22 10:30:37 |   at org.apache.commons.el.ExpressionEvaluatorImpl.evaluate(ExpressionEvaluatorImpl.java:263)
2011/08/22 10:30:37 |   at org.apache.commons.el.ExpressionEvaluatorImpl.evaluate(ExpressionEvaluatorImpl.java:190)
2011/08/22 10:30:37 |   at org.apache.jasper.runtime.PageContextImpl.proprietaryEvaluate(PageContextImpl.java:899)
2011/08/22 10:30:37 |   at i2p.bote.jsp.folder_jsp._jspx_meth_c_set_30(folder_jsp.java:1577)
2011/08/22 10:30:37 |   at i2p.bote.jsp.folder_jsp._jspx_meth_c_forEach_0(folder_jsp.java:1459)
2011/08/22 10:30:37 |   at i2p.bote.jsp.folder_jsp._jspx_meth_ib_requirePassword_0(folder_jsp.java:313)
2011/08/22 10:30:37 |   at i2p.bote.jsp.folder_jsp._jspService(folder_jsp.java:124)
2011/08/22 10:30:37 |   at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:94)
2011/08/22 10:30:37 |   at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
2011/08/22 10:30:37 |   at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:428)
2011/08/22 10:30:37 |   at org.mortbay.jetty.servlet.WebApplicationHandler.dispatch(WebApplicationHandler.java:473)
2011/08/22 10:30:37 |   at org.mortbay.jetty.servlet.Dispatcher.dispatch(Dispatcher.java:286)
2011/08/22 10:30:37 |   at org.mortbay.jetty.servlet.Dispatcher.forward(Dispatcher.java:171)
2011/08/22 10:30:37 |   at org.apache.jasper.runtime.PageContextImpl.doForward(PageContextImpl.java:670)
2011/08/22 10:30:37 |   at org.apache.jasper.runtime.PageContextImpl.forward(PageContextImpl.java:637)
2011/08/22 10:30:37 |   at i2p.bote.jsp.index_jsp._jspService(index_jsp.java:44)
2011/08/22 10:30:37 |   at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:94)
2011/08/22 10:30:37 |   at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
2011/08/22 10:30:37 |   at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:428)
2011/08/22 10:30:37 |   at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplicationHandler.java:830)
2011/08/22 10:30:37 |   at i2p.bote.web.CharsetFilter.doFilter(CharsetFilter.java:38)
2011/08/22 10:30:37 |   at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplicationHandler.java:821)
2011/08/22 10:30:37 |   at org.mortbay.jetty.servlet.WebApplicationHandler.dispatch(WebApplicationHandler.java:471)
2011/08/22 10:30:37 |   at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:568)
2011/08/22 10:30:37 |   at org.mortbay.http.HttpContext.handle(HttpContext.java:1535)
2011/08/22 10:30:37 |   at org.mortbay.jetty.servlet.WebApplicationContext.handle(WebApplicationContext.java:633)
2011/08/22 10:30:37 |   at org.mortbay.http.HttpContext.handle(HttpContext.java:1487)
2011/08/22 10:30:37 |   at org.mortbay.http.HttpServer.service(HttpServer.java:909)
2011/08/22 10:30:37 |   at org.mortbay.http.HttpConnection.service(HttpConnection.java:820)
2011/08/22 10:30:37 |   at org.mortbay.http.HttpConnection.handleNext(HttpConnection.java:986)
2011/08/22 10:30:37 |   at org.mortbay.http.HttpConnection.handle(HttpConnection.java:837)
2011/08/22 10:30:37 |   at org.mortbay.http.SocketListener.handleConnection(SocketListener.java:245)
2011/08/22 10:30:37 |   at org.mortbay.util.ThreadedServer.handle(ThreadedServer.java:357)
2011/08/22 10:30:37 |   at org.mortbay.util.ThreadPool$PoolThread.run(ThreadPool.java:534)
2011/08/22 10:30:37 | Warning - New context not replacing old one, you now have a second one
2011/08/22 10:30:37 | java.lang.Exception: I did it
2011/08/22 10:30:37 |   at net.i2p.I2PAppContext.<init>(I2PAppContext.java:194)
2011/08/22 10:30:37 |   at net.i2p.I2PAppContext.<init>(I2PAppContext.java:163)
2011/08/22 10:30:37 |   at i2p.bote.crypto.NTRUEncrypt1087_GMSS512.<init>(NTRUEncrypt1087_GMSS512.java:109)
2011/08/22 10:30:37 |   at i2p.bote.crypto.CryptoFactory.init(CryptoFactory.java:61)
2011/08/22 10:30:37 |   at i2p.bote.crypto.CryptoFactory.getInstances(CryptoFactory.java:45)
2011/08/22 10:30:37 |   at i2p.bote.email.EmailDestination.extractBase64Dest(EmailDestination.java:102)
2011/08/22 10:30:37 |   at i2p.bote.email.AddressDisplayFilter.getNameAndDestination(AddressDisplayFilter.java:59)
2011/08/22 10:30:37 |   at i2p.bote.web.JSPHelper.getNameAndDestination(JSPHelper.java:520)
2011/08/22 10:30:37 |   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
2011/08/22 10:30:37 |   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
2011/08/22 10:30:37 |   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
2011/08/22 10:30:37 |   at java.lang.reflect.Method.invoke(Method.java:616)
2011/08/22 10:30:37 |   at org.apache.commons.el.FunctionInvocation.evaluate(FunctionInvocation.java:172)
2011/08/22 10:30:37 |   at org.apache.commons.el.ExpressionEvaluatorImpl.evaluate(ExpressionEvaluatorImpl.java:263)
2011/08/22 10:30:37 |   at org.apache.commons.el.ExpressionEvaluatorImpl.evaluate(ExpressionEvaluatorImpl.java:190)
2011/08/22 10:30:37 |   at org.apache.jasper.runtime.PageContextImpl.proprietaryEvaluate(PageContextImpl.java:899)
2011/08/22 10:30:37 |   at i2p.bote.jsp.folder_jsp._jspx_meth_c_set_30(folder_jsp.java:1577)
2011/08/22 10:30:37 |   at i2p.bote.jsp.folder_jsp._jspx_meth_c_forEach_0(folder_jsp.java:1459)
2011/08/22 10:30:37 |   at i2p.bote.jsp.folder_jsp._jspx_meth_ib_requirePassword_0(folder_jsp.java:313)
2011/08/22 10:30:37 |   at i2p.bote.jsp.folder_jsp._jspService(folder_jsp.java:124)
2011/08/22 10:30:37 |   at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:94)
2011/08/22 10:30:37 |   at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
2011/08/22 10:30:37 |   at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:428)
2011/08/22 10:30:37 |   at org.mortbay.jetty.servlet.WebApplicationHandler.dispatch(WebApplicationHandler.java:473)
2011/08/22 10:30:37 |   at org.mortbay.jetty.servlet.Dispatcher.dispatch(Dispatcher.java:286)
2011/08/22 10:30:37 |   at org.mortbay.jetty.servlet.Dispatcher.forward(Dispatcher.java:171)
2011/08/22 10:30:37 |   at org.apache.jasper.runtime.PageContextImpl.doForward(PageContextImpl.java:670)
2011/08/22 10:30:37 |   at org.apache.jasper.runtime.PageContextImpl.forward(PageContextImpl.java:637)
2011/08/22 10:30:37 |   at i2p.bote.jsp.index_jsp._jspService(index_jsp.java:44)
2011/08/22 10:30:37 |   at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:94)
2011/08/22 10:30:37 |   at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
2011/08/22 10:30:37 |   at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:428)
2011/08/22 10:30:37 |   at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplicationHandler.java:830)
2011/08/22 10:30:37 |   at i2p.bote.web.CharsetFilter.doFilter(CharsetFilter.java:38)
2011/08/22 10:30:37 |   at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplicationHandler.java:821)
2011/08/22 10:30:37 |   at org.mortbay.jetty.servlet.WebApplicationHandler.dispatch(WebApplicationHandler.java:471)
2011/08/22 10:30:37 |   at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:568)
2011/08/22 10:30:37 |   at org.mortbay.http.HttpContext.handle(HttpContext.java:1535)
2011/08/22 10:30:37 |   at org.mortbay.jetty.servlet.WebApplicationContext.handle(WebApplicationContext.java:633)
2011/08/22 10:30:37 |   at org.mortbay.http.HttpContext.handle(HttpContext.java:1487)
2011/08/22 10:30:37 |   at org.mortbay.http.HttpServer.service(HttpServer.java:909)
2011/08/22 10:30:37 |   at org.mortbay.http.HttpConnection.service(HttpConnection.java:820)
2011/08/22 10:30:37 |   at org.mortbay.http.HttpConnection.handleNext(HttpConnection.java:986)
2011/08/22 10:30:37 |   at org.mortbay.http.HttpConnection.handle(HttpConnection.java:837)
2011/08/22 10:30:37 |   at org.mortbay.http.SocketListener.handleConnection(SocketListener.java:245)
2011/08/22 10:30:37 |   at org.mortbay.util.ThreadedServer.handle(ThreadedServer.java:357)
2011/08/22 10:30:37 |   at org.mortbay.util.ThreadPool$PoolThread.run(ThreadPool.java:534)

Subtickets

Change History (2)

comment:1 Changed 8 years ago by zzz

  • Owner set to HungryHobo
  • Priority changed from major to minor
  • Status changed from new to assigned

comment:2 Changed 7 years ago by HungryHobo

  • Resolution set to fixed
  • Status changed from assigned to closed

I have never seen this in my logs, but the problem is obviously that I'm creating a new context when I should be using the global context. I checked a fix into MTN.

Note: See TracTickets for help on using tickets.