Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#533 closed defect (fixed)

ERROR [rtup tunnels] eaming.I2PSocketManagerFactory: Error creating session for socket manager

Reported by: DISABLED Owned by: zzz
Priority: minor Milestone: 0.8.10
Component: router/transport Version: 0.8.9
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

Hi zzz,

After the new update of i2p, i has become this error:

13.10.11 15:45:06 ERROR [rtup tunnels] .i2ptunnel.I2PTunnelClientBase: Unable to connect to the router at 127.0.0.1:7654 and build tunnels for the client, retrying in 20 seconds
13.10.11 15:45:06 ERROR [rtup tunnels] eaming.I2PSocketManagerFactory: Error creating session for socket manager

net.i2p.client.I2PSessionException: [shared clients #21193]: Cannot connect to the router on [internal connection]:0
at net.i2p.client.I2PSessionImpl.connect(I2PSessionImpl.java:421)
at net.i2p.client.streaming.I2PSocketManagerFactory.createManager(I2PSocketManagerFactory.java:154)
at net.i2p.client.streaming.I2PSocketManagerFactory.createManager(I2PSocketManagerFactory.java:79)
at net.i2p.i2ptunnel.I2PTunnelClientBase.buildSocketManager(I2PTunnelClientBase.java:424)
at net.i2p.i2ptunnel.I2PTunnelClientBase.buildSocketManager(I2PTunnelClientBase.java:379)
at net.i2p.i2ptunnel.I2PTunnelClientBase.getSocketManager(I2PTunnelClientBase.java:341)
at net.i2p.i2ptunnel.I2PTunnelClientBase.getSocketManager(I2PTunnelClientBase.java:299)
at net.i2p.i2ptunnel.I2PTunnelClientBase.verifySocketManager(I2PTunnelClientBase.java:281)
at net.i2p.i2ptunnel.I2PTunnelClientBase.<init>(I2PTunnelClientBase.java:207)
at net.i2p.i2ptunnel.I2PTunnelClientBase.<init>(I2PTunnelClientBase.java:153)
at net.i2p.i2ptunnel.I2PTunnelHTTPClientBase.<init>(I2PTunnelHTTPClientBase.java:65)
at net.i2p.i2ptunnel.I2PTunnelHTTPClient.<init>(I2PTunnelHTTPClient.java:224)
at net.i2p.i2ptunnel.I2PTunnel.runHttpClient(I2PTunnel.java:763)
at net.i2p.i2ptunnel.TunnelController?.startHttpClient(TunnelController?.java:211)
at net.i2p.i2ptunnel.TunnelController?.doStartTunnel(TunnelController?.java:171)
at net.i2p.i2ptunnel.TunnelController?.startTunnel(TunnelController?.java:132)
at net.i2p.i2ptunnel.TunnelControllerGroup?$StartControllers?.run(TunnelControllerGroup?.java:137)
at java.lang.Thread.run(Thread.java:636)
at net.i2p.util.I2PThread.run(I2PThread.java:85)
Caused by: java.io.IOException: No tunnels built after waiting 5 minutes… are there network problems?
at net.i2p.client.I2PSessionImpl.connect(I2PSessionImpl.java:398)
… 18 more

I2P version: 0.8.9-0deb1

Java version: Sun Microsystems Inc. 1.6.0_20 (OpenJDK Runtime Environment 1.6.0_20-b20)
Wrapper version: 3.5.12
Platform: Linux amd64 2.6.38-10-generic
Processor: uninitialized (core2)
Jbigi: Locally optimized native BigInteger? library loaded from file
Encoding: UTF-8

I running Kubuntu Lucid (Ubuntu 10.04.3
LTS Release: 10.04 ) :

Subtickets

Attachments (2)

log-router-0.txt (9.7 KB) - added by DISABLED 8 years ago.
log-router-1.txt (2.1 KB) - added by DISABLED 8 years ago.

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by DISABLED

Attachment: log-router-0.txt added

Changed 8 years ago by DISABLED

Attachment: log-router-1.txt added

comment:1 Changed 8 years ago by zzz

The problem in the text (from log-router-1.txt) is a normal error when the router cannot build tunnels, either because you have network connection problems, or I2P is severely overloaded and everybody is rejecting your tunnels. The network is super-overloaded right now so that may be the explanation.

The problem from log-router-0.txt is that you are OutOfMemory?. Increase wrapper.java.maxmemory in $I2P/wrapper.config, stop I2P completely, and restart.

A couple of the other errors I will change to warnings in 0.8.9-1.

comment:2 Changed 8 years ago by zzz

Resolution: fixed
Status: newclosed

Errors changed to warns in 0.8.9-1.

comment:3 Changed 8 years ago by DISABLED

Hi zzz,

Thanks for your comment, i have increase the wrapper.java.maxmemory in $I2P/wrapper.config to 512 and look to be good so far…

Best regards

stars

Note: See TracTickets for help on using tickets.