Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#535 closed defect (fixed)

ATTENTION: Error for /summaryframe.jsp

Reported by: DISABLED Owned by: zzz
Priority: major Milestone: 0.8.10
Component: router/general Version: 0.8.9
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

Hi zzz,

here are another error message who make crashing i2p:

2011/10/14 14:19:12 | 14 oct. 2011 12:19:12 org.mortbay.jetty.servlet.ServletHandler? handle
2011/10/14 14:19:12 | ATTENTION: Error for /summaryframe.jsp
2011/10/14 14:19:12 | java.lang.NoClassDefFoundError?: javax/servlet/jsp/SkipPageException
2011/10/14 14:19:12 | at net.i2p.router.web.jsp.summaryframe_jsp._jspService(summaryframe_jsp.java:269)
2011/10/14 14:19:12 | at org.apache.jasper.runtime.HttpJspBase?.service(HttpJspBase?.java:94)
2011/10/14 14:19:12 | at javax.servlet.http.HttpServlet?.service(HttpServlet?.java:689)
2011/10/14 14:19:12 | at org.mortbay.jetty.servlet.ServletHolder?.handle(ServletHolder?.java:428)
2011/10/14 14:19:12 | at org.mortbay.jetty.servlet.WebApplicationHandler?.dispatch(WebApplicationHandler?.java:473)
2011/10/14 14:19:12 | at org.mortbay.jetty.servlet.ServletHandler?.handle(ServletHandler?.java:568)
2011/10/14 14:19:12 | at net.i2p.router.web.LocaleWebAppHandler?.handle(LocaleWebAppHandler?.java:90)
2011/10/14 14:19:12 | at org.mortbay.http.HttpContext?.handle(HttpContext?.java:1535)
2011/10/14 14:19:12 | at org.mortbay.jetty.servlet.WebApplicationContext?.handle(WebApplicationContext?.java:633)
2011/10/14 14:19:12 | at org.mortbay.http.HttpContext?.handle(HttpContext?.java:1487)
2011/10/14 14:19:12 | at org.mortbay.http.HttpServer?.service(HttpServer?.java:909)
2011/10/14 14:19:12 | at org.mortbay.http.HttpConnection?.service(HttpConnection?.java:820)
2011/10/14 14:19:12 | at org.mortbay.http.HttpConnection?.handleNext(HttpConnection?.java:986)
2011/10/14 14:19:12 | at org.mortbay.http.HttpConnection?.handle(HttpConnection?.java:837)
2011/10/14 14:19:12 | at org.mortbay.http.SocketListener?.handleConnection(SocketListener?.java:245)
2011/10/14 14:19:12 | at org.mortbay.util.ThreadedServer?.handle(ThreadedServer?.java:357)
2011/10/14 14:19:12 | at org.mortbay.util.ThreadPool?$PoolThread?.run(ThreadPool?.java:534)
2011/10/14 14:19:12 | Caused by: java.lang.ClassNotFoundException?: javax.servlet.jsp.SkipPageException?
2011/10/14 14:19:12 | at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
2011/10/14 14:19:12 | at java.security.AccessController?.doPrivileged(Native Method)
2011/10/14 14:19:12 | at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
2011/10/14 14:19:12 | at org.mortbay.http.ContextLoader?.loadClass(ContextLoader?.java:219)
2011/10/14 14:19:12 | at org.mortbay.http.ContextLoader?.loadClass(ContextLoader?.java:187)
2011/10/14 14:19:12 | … 17 more
2011/10/14 14:19:12 | 14 oct. 2011 12:19:12 org.mortbay.http.HttpConnection? exception
2011/10/14 14:19:12 | ATTENTION: GET /summaryframe.jsp HTTP/1.1
2011/10/14 14:19:12 | java.io.IOException: closed
2011/10/14 14:19:12 | at org.mortbay.http.HttpOutputStream?.prepareOutput(HttpOutputStream?.java:452)
2011/10/14 14:19:12 | at org.mortbay.http.HttpOutputStream?.write(HttpOutputStream?.java:421)
2011/10/14 14:19:12 | at sun.nio.cs.StreamEncoder?.writeBytes(StreamEncoder?.java:220)
2011/10/14 14:19:12 | at sun.nio.cs.StreamEncoder?.implFlushBuffer(StreamEncoder?.java:290)
2011/10/14 14:19:12 | at sun.nio.cs.StreamEncoder?.implFlush(StreamEncoder?.java:294)
2011/10/14 14:19:12 | at sun.nio.cs.StreamEncoder?.flush(StreamEncoder?.java:140)
2011/10/14 14:19:12 | at java.io.OutputStreamWriter?.flush(OutputStreamWriter?.java:229)
2011/10/14 14:19:12 | at org.mortbay.http.HttpOutputStream?$HttpWriter?.flush(HttpOutputStream?.java:798)
2011/10/14 14:19:12 | at org.mortbay.http.HttpOutputStream?.resetStream(HttpOutputStream?.java:360)
2011/10/14 14:19:12 | at org.mortbay.http.HttpConnection?.handleNext(HttpConnection?.java:1074)
2011/10/14 14:19:12 | at org.mortbay.http.HttpConnection?.handle(HttpConnection?.java:837)
2011/10/14 14:19:12 | at org.mortbay.http.SocketListener?.handleConnection(SocketListener?.java:245)
2011/10/14 14:19:12 | at org.mortbay.util.ThreadedServer?.handle(ThreadedServer?.java:357)
2011/10/14 14:19:12 | at org.mortbay.util.ThreadPool?$PoolThread?.run(ThreadPool?.java:534)
2011/10/14 14:22:21 | CRIT [W pumper 2/4] net.i2p.router.Router : Shutdown(10) complete
2011/10/14 14:22:21 | CRIT 3/4? net.i2p.router.Router : Shutdown(10) complete
2011/10/14 14:22:21 | CRIT [W pumper 4/4] net.i2p.router.Router : Shutdown(10) complete
2011/10/14 14:22:21 | CRIT [W pumper ¾] net.i2p.router.Router : Shutdown(10) complete
2011/10/14 14:22:21 | CRIT [NTCP Pumper ] net.i2p.router.Router : Shutdown(10) complete
2011/10/14 14:22:25 | on_exit trigger matched. Restarting the JVM. (Exit code: 10)

kUBUNTU Lucid 64 bits


I2P version: 0.8.9-0deb1

Java version: Sun Microsystems Inc. 1.6.0_20 (OpenJDK Runtime Environment 1.6.0_20-b20)
Wrapper version: 3.5.12
Platform: Linux amd64 2.6.38-10-generic
Processor: uninitialized (core2)
Jbigi: Locally optimized native BigInteger? library loaded from file
Encoding: UTF-8

Subtickets

Attachments (2)

log-router-0.txt (3.2 KB) - added by DISABLED 8 years ago.
wrapper.log (110.2 KB) - added by DISABLED 8 years ago.

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by DISABLED

Attachment: log-router-0.txt added

Changed 8 years ago by DISABLED

Attachment: wrapper.log added

comment:1 Changed 8 years ago by zzz

Owner: set to zzz
Priority: criticalmajor
Status: newaccepted

You are running out of memory. Shut down I2P, increase wrapper.java.maxmemory in $I2P/wrapper.config, and restart. You also appear to be running out of memory very early in the startup process. This may be because you have set very high bandwidth limits - the router allocates more memory when it is configured for high bandwidth. Lower the bandwidth settings on /config.

I'll fix the NPEs in RouterThrottleImpl? and FloodfillPeerSelector?.

comment:2 Changed 8 years ago by zzz

Component: wrapperrouter/general
Resolution: fixed
Status: acceptedclosed

NPEs fixed in 0.8.9-1.

comment:3 Changed 8 years ago by DISABLED

Hi zzz,

thanks very much for your answer, i have increase my memory limit and so far look good

Best regards

stars

Note: See TracTickets for help on using tickets.