Opened 8 years ago

Closed 7 years ago

#537 closed defect (not a bug)

router shut itself down

Reported by: DISABLED Owned by:
Priority: minor Milestone: 0.8.12
Component: router/general Version: 0.8.9
Keywords: router and wrapper stopped Cc:
Parent Tickets: Sensitive: no

Description

After a day or so of uptime the router suddenly was off.
entire wrapper.log: http://pastethis.i2p/show/GWBt5F4ZyQovIf82tPra/

Subtickets

Change History (6)

comment:1 Changed 8 years ago by zzz

wow.
Whatever caused the shutdown happened before the part you pasted. Check the other files wrapper.log.1, wrapper.log.2, etc. for the beginning, it got split across two files.

But just in the part you pasted, I count 112 TrackerClient? threads, which means at least 112 torrents. That's way way too many unless you have increased your wrapper.java.maxmemory in wrapper.config. Even then, I recommend no more than 10 or 20 running torrents.

So I suspect you are running out of memory, or there's some other consequence of running so many torrents, like severe contention for CPU or bandwidth.

If you find the beginning part of the logs please attach.

comment:2 Changed 8 years ago by DISABLED

yes there are a few active torrents in i2psnark.
ok, here's the wrapper.log.1 from the time of the router start onward: http://pastethis.i2p/show/RtfUyqHEEfME49DgXOHX/

comment:3 Changed 8 years ago by zzz

Component: unspecifiedrouter/general

OK.

The thread dump occurred because the router became completely unresponsive.

What I see from the additional log is another 60+ torrents (that's almost 200 total), plus seedless (with a large number of threads), i2pbote (a large number of threads also), and an active eepsite.

I don't know your hardware, your RAM, your bandwidth, or your maxmemory setting in wrapper.config. I don't need to know.

I don't know if you are the same poster of the other recent tickets with lots of OutOfMemory? errors. It doesn't matter.

You're trying to do WAY too much. Start out with 5 or 10 torrents. Or i2pbote. Or seedless. Or an eepsite. See how the performance is. Then SLOWLY add things over a period of DAYS. When the performance becomes poor, back off a little. If you get OutOfMemory? errors, increase the setting in wrapper.config or back off a little.

comment:4 Changed 8 years ago by DISABLED

no, no out of memory errors here. and since that shut off of this post it's been running smoothly (19 hours now). ram i have 4GB on this machine. most of the 191 torrents are seeding not downloading

comment:5 Changed 8 years ago by DISABLED

if you say it maybe too much things at the same time, then mabe it happened when I was watching some youtube videos or videos from hard drive. but maybe I was not doing anything else. I don't remember. but there are always a few other apps running at the same time too

comment:6 Changed 7 years ago by zzz

Resolution: not a bug
Status: newclosed
Note: See TracTickets for help on using tickets.