Opened 7 years ago

Closed 7 years ago

#560 closed defect (fixed)

big downloads fail

Reported by: echelon Owned by:
Priority: minor Milestone: 0.8.12
Component: streaming Version: 0.8.11
Keywords: Cc:
Parent Tickets:

Description

I try to fetch big files via my outproxy on 0 hop base.
til today it was fine, but with 0.8.11-13 it is no more.
(last time I really tried was 0.8.11).
It fetches a few MB with 500-600kb/sec, it stops for 40-80 sec, it gets backup again up to 600 kb/sec, it goes down again...
Like a wave. Wasn´t that way with 0.8.11. No entry in logs, no real problem I do know with router so far.

Subtickets

Change History (3)

comment:1 Changed 7 years ago by zzz

  • Component changed from www to streaming
  • Priority changed from major to minor

<zzz> re: downloads, that's with what sponge calls 'loopback', i.e. client-to-server on same router?
<zzz> or different routers?
<eche|offf> but currently my head is somewhere else, I just can tell: it is not worse than befoire and simplier
<eche|offf> zzz: yes, it is "loopback"
<eche|offf> same router
<eche|offf> looks like you changed some connection sin there
<zzz> No changes I can think of since 0.8.11 release that would affect that. Sponge has seen those pauses for years.
<eche|offf> hm
<eche|offf> it did worked always quite fast
<eche|offf> and I did not changed anything I know of beside the new rev
<zzz> sponge's theory is that it may indicate some bug in streaming. my theory is that streaming is not tuned for zero-latency, it's harmless and low priority problem. Don't know who's right
<eche|offf> I could fetch a 100 MB file with 1 MB/sec that way in short time, now it takes long time
<eche|offf> (I just ssh to server and connect proxy to routers www proxy which goes direct to squid3)

comment:2 Changed 7 years ago by sponge

@echelon:
The test file wouldn't happen to be highly compressible, would it? If so, you may be seeing the action of gzip, although I though that zzz zapped that one... I could be wrong.

comment:3 Changed 7 years ago by sponge

  • Resolution set to fixed
  • Status changed from new to closed

The timout was wrong for the http proxy, and was fixed.

Note: See TracTickets for help on using tickets.