Opened 8 years ago

Closed 7 years ago

#563 closed defect (fixed)

i2psnark TrackerClient thread hangs occasionally

Reported by: zzz Owned by: zzz
Priority: minor Milestone: 0.9.1
Component: apps/i2psnark Version: 0.8.11
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

Symptom: Stuck at 'Peers 0/n' when seeding when you know there are lots of leeches out there. Stopping and restarting the torrent gets things going again. May also happen when leeching.

This is apparently due to the TrackerClient? thread getting stuck so it isn't announcing to the tracker any more. Perhaps some timeout isn't working any more… possibly due to changes in EepGet? or streaming.

This is relatively rare. Need a thread dump to diagnose and I haven't been able to catch it yet.

Subtickets

Change History (5)

comment:1 Changed 8 years ago by zzz

Milestone: 0.8.140.9.3

comment:2 Changed 8 years ago by zzz

seen again 0.8.13-23

comment:3 Changed 7 years ago by DISABLED

Maybe this will help you to find the bug ..


Comment by: anon user, Added: 2012-07-09 11:14:50, Edited: never
@Leecher
Since 12 hours Your clients denied to download it.
Restart your Snark with a new ID (i2psnark → Stop All, not just only the torrent!)
This seems to be a problem by half of all snarks since a while, mostly those that are listed with 100% but without any parts have problems to load a first piece.
Seems someone shut report this to the devs. I'll not do this.
There should be out a lot of poeple that recognized this allready because they won't download anything untill a second leecher comes and share a first part with them.

Your case is hard because you have no chance to get a first piece from somebody else than from me as you are the only one leecher, so restart I2PSnark!

  • Reseeder

—-

Comment by: anon user, Added: 2012-07-09 11:28:03, Edited: never
For the Bugreport some additional infos:
Those clients doesn't keep the connection to the Seeder long enought to request a pieces.
Connection Intervall and Handshakes are succesful but the reanswer (of the Seeder) failt because the peer of the leecher is allready closed!

—-

Comment by: anon user, Added: 2012-07-09 11:56:30, Edited: never
Second additional info for bugreport:

Find the reason why some leechers without any parts are listed as 100% on Postman and you might find a hint for a bugfix.
There seems to be a coherence between this behaviour and the closing of the connection by the leecher to the seeder(s) during handshake or immediately(?) after the handshake. The duration of connection time at my side (as seeder) to the leecher is listed allways as 0 seconds in the logs but the connection was once succesful etablished! At least long enough to get a complete Client report to handle AFTER the handshake!


comment:4 Changed 7 years ago by zzz

Milestone: 0.9.30.9.1
Status: newaccepted

I think I found the cause and it's fixed in about 0.9-19. Torrents that were started, stopped, and restarted wouldn't announce properly. Lots of other snark changes will be in 0.9.1 also, so I will leave this ticket open until after the release and see how it goes.

comment:5 Changed 7 years ago by zzz

Resolution: fixed
Status: acceptedclosed
Note: See TracTickets for help on using tickets.