Opened 7 years ago

Closed 7 years ago

#574 closed defect (fixed)

irc tunnel will not reconnect

Reported by: echelon Owned by: zzz
Priority: major Milestone: 0.9
Component: api/crypto Version: 0.8.11
Keywords: Cc:
Parent Tickets:

Description

Sometimes 0.8.11-x will loose connection to IRC server and tries to reconnect, will will not reach any server.
It keeps in this state forever - IRC client tunnel is up but it will not find any IRC server and connect to it.
Stop tunnel, start tunnel and you connect to IRC server again.
It happens with 1,2 or 3 IRC servers in "irc client destination" line entered.
Some reports in forum do show it may happen with http proxy, to. Those reports shows, it does not append to SAMv3 or BOB.

echelon

Subtickets

Change History (4)

comment:1 Changed 7 years ago by zzz

  • Component changed from streaming to api/general
  • Milestone changed from 0.8.12 to 0.9
  • Status changed from new to accepted

Postman confirmed that some of this is due to fairly tight streaming connection limits configured on both irc.postman.i2p and irc.freshcoffee.i2p. You may wish to work with him to investigate raising the limits.

However, kytv and others have done some good work on logging the problem on a server w/o conn limits. It appears to be ElG/Session tag decrypt fails at the server. This is probably due to speculative use of unacked session tags by the client. It may be exacerbated by the low bandwidth connection. Or maybe not.

I need to research why it isn't recovering. The client must either fall back to known-acked tags, or restart with a full ElG. Also, it's time to review the whole assumed-acked-tags technique. Might need tweaks or more.

comment:2 Changed 7 years ago by zzz

  • Component changed from api/general to api/crypto

comment:3 Changed 7 years ago by zzz

Hopefully fixed in 0.8.13-7, but requires fix at both ends for full effect.

Will leave this ticket open while we test.

comment:4 Changed 7 years ago by zzz

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.