Opened 7 years ago

Closed 6 years ago

#582 closed defect (fixed)

error kademia connection (iMule)

Reported by: gilles Owned by: mkvore
Priority: minor Milestone:
Component: apps/other Version: 0.8.12
Keywords: Cc:
Parent Tickets:

Description

Hello,

since the last uodate; I have this bug/
I use imule qith i2p and before had no problem
here is some error
messages I get
2012-01-09 18:23:09: Please report this : length(10302) > UDP_BUFFER_SIZE(10240) in CMuleUDPSocket::OnReceive?. protocol was OP_KADEMLIAHEADER, opcode was unknown.
2012-01-09 18:23:09: Kademlia Routing: CContact::CContact(stream) -> (kad: 001010000011) (dist: 100101101001) (udp: bb28) (tcp: b917)
2012-01-09 18:25:28: Please report this : length(10302) >
UDP_BUFFER_SIZE(10240) in CMuleUDPSocket::OnReceive?. protocol was OP_KADEMLIAHEADER, opcode was unknown.
2012-01-09 18:25:28: Kademlia Routing: CContact::CContact(stream) -> (kad: 101111101010) (dist: 000000000000) (udp: ca8b) (tcp: b284)
2012-01-09 18:27:46: Please report this : length(11884) > UDP_BUFFER_SIZE(10240) in CMuleUDPSocket::OnReceive?. protocol was OP_KADEMLIAHEADER, opcode was unknown.
2012-01-09 18:27:46: Kademlia Routing: CContact::CContact(stream) -> (kad: 110101011010) (dist: 011010110000) (udp: ca4e) (tcp: b646)

Cdlt
Gilles

Subtickets

Attachments (1)

error kademia connection.jpg (64.9 KB) - added by gilles 7 years ago.
error kademia connection

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by gilles

error kademia connection

comment:1 Changed 7 years ago by zzz

  • Component changed from unspecified to apps/other
  • Milestone 0.8.13 deleted

The problem is in iMule and there is no maintainer.

Due to message corruption fixes in 0.8.12, large datagrams are more likely to succeed, so you may see this more often.

comment:2 Changed 7 years ago by zzz

  • Owner set to mkvore
  • Status changed from new to assigned
  • Summary changed from error kademia connection to error kademia connection (iMule)

comment:3 Changed 6 years ago by mkvore

  • Resolution set to fixed
  • Status changed from assigned to closed

This happened when iMule kademlia protocol changed from v1 to v2.
Fixed in iMule 2.3.2 (or earlier).

Note: See TracTickets for help on using tickets.