Opened 8 years ago

Closed 8 years ago

#601 closed defect (not a bug)

Router is rebooted or turns off independently every day

Reported by: mrbug Owned by:
Priority: minor Milestone: 0.8.13
Component: router/general Version: 0.8.12
Keywords: Cc: mrbug@…, killyourtv@…
Parent Tickets: Sensitive: no

Description

Sometimes my router is rebooted or turns off independently.

Logs are attached.

Configuration:
I2P version: 0.8.12-13
Java version: The FreeBSD Foundation 1.6.0_07 (Diablo Java™ SE Runtime Environment 1.6.0_07-b02)
Wrapper version: 3.5.13
Server version: 5.1.15
Platform: FreeBSD amd64 8.2-RELEASE-p4
Processor: Core 2 (Conroe) (core2)
Jbigi: Locally optimized native BigInteger? library loaded from file
Encoding: ISO8859-1
Charset: ISO-8859-1

Installed plugins:
i2pbote 0.2.6-b98
neodatis 2.1-2.14-209-11
seedless 0.0.59-0.0.55

Subtickets

Attachments (1)

logs.zip (189.1 KB) - added by mrbug 8 years ago.
Logs

Download all attachments as: .zip

Change History (8)

Changed 8 years ago by mrbug

Attachment: logs.zip added

Logs

comment:1 Changed 8 years ago by zzz

As the logs make clear you are repeatedly running out of memory. Increase max memory in wrapper.config, or don't run i2pbote and seedless, or both.

The JVM crash I can't explain. If it crashes repeatedly, try running a RAM test or upgrading your JRE.

comment:2 Changed 8 years ago by sponge

@zzz i2p-bote uses seedless. Seedless does not have a large footprint, or at least it shouldn't have enough of one to make that big of a difference unless you run a seedless server. One recommendation I make is for each plugin increase the JVM heap 32MB. That solves 99% of the issues. As far as bote, I've not used it since it tends to pollute the wrapper.log too much still.

@mrbug increase jvm heap by 96MB and you should be fine.

comment:3 Changed 8 years ago by mrbug

Cc: mrbug@… added

Folks,

I've looked to my wrapper.conf. Option for 'Maximum Java Heap Size' is wrapper.java.maxmemory=128 and this is default value after installation.
Now I turned off all plugins.
If the issue will be reproduced, then I'll try to investigate it and give you more information.

Thanks

comment:4 in reply to:  2 Changed 8 years ago by killyourtv

Cc: killyourtv@… added

Replying to sponge:

@zzz i2p-bote uses seedless.

If you mean i2p-bote NEEDS seedless, that's incorrect. For the record, I'm running i2p-bote just fine without seedless.

comment:5 Changed 8 years ago by sponge

No, you don't _need_ it, but it assists in locating peers. mrbug said he's using seedless, so…

comment:6 Changed 8 years ago by mrbug

As seems I solved the problem.
My changes:

  • in ~/i2p/wrapper.conf

'wrapper.java.command=java' → 'wrapper.java.command=/full/path/to/java_binary'
increase 'wrapper.java.maxmemory' to 512

  • in ~/.i2p/clients.config

'clientApp.0.args=7657 ::1,127.0.0.1 ./webapps/' → 'clientApp.0.args=7657 127.0.0.1 ./webapps/'

Thanks

comment:7 Changed 8 years ago by zzz

Resolution: not a bug
Status: newclosed

thanks for the followup

Note: See TracTickets for help on using tickets.