Opened 7 years ago

Closed 7 years ago

#602 closed defect (no response)

Problems on ARMv5

Reported by: wackelPu Owned by:
Priority: minor Milestone:
Component: router/general Version: 0.8.12
Keywords: arm Cc:
Parent Tickets:

Description

Okay.
I have several issues on a Pogoplug (p21) with ARMv5 on archlinuxarm
I installed i2p firstly with openjdk( java -jar i2pinstall* -console ).
I tried it to run both, with and without wrapper. When i run it with wrapper i got error files (hs_err_pid*.log) like this: http://pastethis.i2p/show/753/
some people in irc gave me the advice to use oracle's hotspot java. so i tried it with it, and it still gave me error files, similar to the above linked. but on the head of the file it said

# Problematic frame:
 # C  [libjbigi.so+0x1b8a]  _init+0x411
 #

and i looked in the ~/i2p/ dir and i don't have any .so files there. So there seems to be a problem in the installer, which treats arm probably wrong.

Subtickets

Change History (2)

comment:1 Changed 7 years ago by zzz

where $I2P is your install dir, move the files $I2P/libjbigi.so and $I2P/lib/jbigi.jar someplace outside of $I2P for safekeeping.

You should now be able to start i2p.

The .so file isn't compatible either with your processor or your OS. Try 'ldd libjbigi.so' and see if it is happy. Also please paste the output of cat /proc/cpuinfo below.

Also what is the size in bytes of the libjbigi.so file? That will tell us which one it pulled out of jbigi.jar.

comment:2 Changed 7 years ago by zzz

  • Milestone 0.8.13 deleted
  • Resolution set to no response
  • Status changed from new to closed

please reopen if you add more info.

Note: See TracTickets for help on using tickets.