Opened 8 years ago

Closed 8 years ago

#604 closed defect (not a bug)

Error 500: /config.jsp net/i2p/router/web/ConfigNetHelper

Reported by: DISABLED Owned by:
Priority: minor Milestone:
Component: apps/console Version: 0.8.12
Keywords: internal error Cc:
Parent Tickets: Sensitive: no

Description

Error Details

Error 500: /config.jsp net/i2p/router/web/ConfigNetHelper

java.lang.NoClassDefFoundError?: net/i2p/router/web/ConfigNetHelper

at net.i2p.router.web.jsp.config_jsp._jspService(config_jsp.java:262)
at org.apache.jasper.runtime.HttpJspBase?.service(HttpJspBase?.java:94)
at javax.servlet.http.HttpServlet?.service(HttpServlet?.java:689)
at org.mortbay.jetty.servlet.ServletHolder?.handle(ServletHolder?.java:428)
at org.mortbay.jetty.servlet.WebApplicationHandler?.dispatch(WebApplicationHandler?.java:473)
at org.mortbay.jetty.servlet.ServletHandler?.handle(ServletHandler?.java:568)
at net.i2p.router.web.LocaleWebAppHandler?.handle(LocaleWebAppHandler?.java:90)
at org.mortbay.http.HttpContext?.handle(HttpContext?.java:1535)
at org.mortbay.jetty.servlet.WebApplicationContext?.handle(WebApplicationContext?.java:633)
at org.mortbay.http.HttpContext?.handle(HttpContext?.java:1487)
at org.mortbay.http.HttpServer?.service(HttpServer?.java:909)
at org.mortbay.http.HttpConnection?.service(HttpConnection?.java:820)
at org.mortbay.http.HttpConnection?.handleNext(HttpConnection?.java:986)
at org.mortbay.http.HttpConnection?.handle(HttpConnection?.java:837)
at org.mortbay.http.SocketListener?.handleConnection(SocketListener?.java:245)
at org.mortbay.util.ThreadedServer?.handle(ThreadedServer?.java:357)
at org.mortbay.util.ThreadPool?$PoolThread?.run(ThreadPool?.java:534)
Caused by: java.lang.ClassNotFoundException?: net.i2p.router.web.ConfigNetHelper?
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController?.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at org.mortbay.http.ContextLoader?.loadClass(ContextLoader?.java:219)
at org.mortbay.http.ContextLoader?.loadClass(ContextLoader?.java:187)
… 17 more


I2P Version and Running Environment

I2P version: 0.8.12-0
Java version: Sun Microsystems Inc. 1.6.0_29 (Java™ SE Runtime Environment 1.6.0_29-b11)
Platform: Windows 7 x86 6.1
Processor: Mobile Athlon II/Turion II/Phenom II/Sempron/V-series (Regor/Caspian/Champlain?, 45 nm) (athlon64)
Jbigi: Locally optimized native BigInteger? library loaded from file
Encoding: Cp1252

Subtickets

Change History (3)

comment:1 Changed 8 years ago by zzz

Component: otherapps/console

Very strange. Did you install I2P from our website? If not, from where? It appears your $I2P/lib/routerconsole.jar file is incomplete. If a restart doesn't fix things I recommend a reinstall.

comment:2 Changed 8 years ago by zzz

If your first install was before 0.8.12, then perhaps your upgrade to 0.8.12 was incomplete or corrupted.

comment:3 Changed 8 years ago by zzz

Milestone: 0.8.13
Resolution: not a bug
Status: newclosed
Note: See TracTickets for help on using tickets.