Opened 7 years ago

Closed 7 years ago

#612 closed defect (not a bug)

internal error

Reported by: DISABLED Owned by:
Priority: minor Milestone:
Component: apps/console Version: 0.8.12
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

Error Details

Error 500: / net/i2p/router/web/SummaryHelper$AlphaComparator?

java.lang.NoClassDefFoundError?: net/i2p/router/web/SummaryHelper$AlphaComparator?

at net.i2p.router.web.SummaryHelper?.getDestinations(SummaryHelper?.java:372)
at net.i2p.router.web.SummaryBarRenderer?.renderSummaryHTML(SummaryBarRenderer?.java:445)
at net.i2p.router.web.SummaryHelper?.renderSummaryBar(SummaryHelper?.java:607)
at net.i2p.router.web.jsp.index_jsp._jspService(index_jsp.java:231)
at org.apache.jasper.runtime.HttpJspBase?.service(HttpJspBase?.java:94)
at javax.servlet.http.HttpServlet?.service(HttpServlet?.java:689)
at org.mortbay.jetty.servlet.ServletHolder?.handle(ServletHolder?.java:428)
at org.mortbay.jetty.servlet.WebApplicationHandler?.dispatch(WebApplicationHandler?.java:473)
at org.mortbay.jetty.servlet.ServletHandler?.handle(ServletHandler?.java:568)
at net.i2p.router.web.LocaleWebAppHandler?.handle(LocaleWebAppHandler?.java:90)
at org.mortbay.http.HttpContext?.handle(HttpContext?.java:1535)
at org.mortbay.jetty.servlet.WebApplicationContext?.handle(WebApplicationContext?.java:633)
at org.mortbay.http.HttpContext?.handle(HttpContext?.java:1487)
at org.mortbay.http.HttpServer?.service(HttpServer?.java:909)
at org.mortbay.http.HttpConnection?.service(HttpConnection?.java:820)
at org.mortbay.http.HttpConnection?.handleNext(HttpConnection?.java:986)
at org.mortbay.http.HttpConnection?.handle(HttpConnection?.java:837)
at org.mortbay.http.SocketListener?.handleConnection(SocketListener?.java:245)
at org.mortbay.util.ThreadedServer?.handle(ThreadedServer?.java:357)
at org.mortbay.util.ThreadPool?$PoolThread?.run(ThreadPool?.java:534)
Caused by: java.lang.ClassNotFoundException?: net.i2p.router.web.SummaryHelper?$AlphaComparator?
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController?.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader?.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader?.loadClass(Unknown Source)
at java.lang.ClassLoader?.loadClass(Unknown Source)
… 20 more


I2P Version and Running Environment

I2P version: 0.8.12-0
Java version: Sun Microsystems Inc. 1.6.0_25 (Java™ SE Runtime Environment 1.6.0_25-b06)
Platform: Windows Vista x86 6.0
Processor: Core 2 (Conroe) (core2)
Jbigi: Locally optimized native BigInteger? library loaded from file
Encoding: Cp1252

Note that system information, log timestamps, and log messages may provide clues to your location; please review everything you include in a bug report.

Subtickets

Change History (1)

comment:1 Changed 7 years ago by zzz

Component: unspecifiedapps/console
Milestone: 0.9
Resolution: not a bug
Status: newclosed

This appears similar to #604 - your routerconsole.jar is corrupt, that class should be there. Upgrade or reinstall.

How did you originally install? If before 0.8.12, hos did you upgrade to 0.8.12?

Note: See TracTickets for help on using tickets.