Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#615 closed defect (invalid)

java7 jdk does not built i2pinstall.exe with launch4j

Reported by: Eche|on Owned by:
Priority: minor Milestone: 0.9
Component: package/other Version: 0.8.13
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

Just got my server running with oracle java7 update 3 jdk.
Grabbed source and try to built 0.8.13-7.
On launch4j it spew out:

buildProperties:

[echo] Building version 0.8.13-7 (mtn rev c13ca34c4bb2dae64c3497aa6507bc551 bd3c297)

doBuildEXE:

[echo] See the file "build.properties" if this step fails.

[jar] Building MANIFEST-only jar: /usr/src/i2p/i2p.i2p/build/launchi2p.jar

[launch4j] Compiling resources
[launch4j] Generated resource file…
[launch4j]
[launch4j] LANGUAGE 0, 1
[launch4j] 2 RCDATA BEGIN "1.5.0\0" END
[launch4j] 18 RCDATA BEGIN "1\0" END
[launch4j] 27 RCDATA BEGIN "128\0" END
[launch4j] 12 RCDATA BEGIN "-Djava.library.path=.;lib -DloggerFilenameOverride?= logs/log-router-@.txt -Dorg.mortbay.http.Version.paranoid=true -Dorg.mortbay.uti l.FileResource?.checkAliases=false\0" END
[launch4j] 1 ICON DISCARDABLE "/usr/src/i2p/i2p.i2p/installer/resources/start.i co"
[launch4j] 10 RCDATA BEGIN "I2P\0" END
[launch4j] 21 RCDATA BEGIN "http://java.com/download\0" END
[launch4j] 8 RCDATA BEGIN ".\0" END
[launch4j] 20 RCDATA BEGIN "32\0" END
[launch4j] 4 RCDATA BEGIN "true\0" END
[launch4j] 6 RCDATA BEGIN "10\0" END
[launch4j] 1 BITMAP "/usr/src/i2p/i2p.i2p/installer/resources/i2plogo.bmp"
[launch4j] 101 RCDATA BEGIN "An error occurred while starting the application.\ 0" END
[launch4j] 102 RCDATA BEGIN "This application was configured to use a bundled J ava Runtime Environment but the runtime is missing or corrupted.\0" END
[launch4j] 103 RCDATA BEGIN "This application requires a Java Runtime Environme nt\0" END
[launch4j] 104 RCDATA BEGIN "The registry refers to a nonexistent Java Runtime Environment installation or the runtime is corrupted.\0" END
[launch4j] 17 RCDATA BEGIN "true\0" END
[launch4j]

BUILD FAILED
/usr/src/i2p/i2p.i2p/build.xml:230: The following error occurred while executing this line:
/usr/src/i2p/i2p.i2p/build.xml:250: net.sf.launch4j.BuilderException?: net.sf.lau nch4j.ExecException?: java.io.IOException: Cannot run program "/usr/src/i2p/i2p.i 2p/installer/lib/launch4j/bin/windres": error=2, Datei oder Verzeichnis nicht ge funden

at net.sf.launch4j.Builder.build(Builder.java:144)
at net.sf.launch4j.ant.Launch4jTask.execute(Launch4jTask.java:111)
at org.apache.tools.ant.UnknownElement?.execute(UnknownElement?.java:291)
at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl?.invoke(DelegatingMethodAcces? sorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:601)
at org.apache.tools.ant.dispatch.DispatchUtils?.execute(DispatchUtils?.jav a:106)
at org.apache.tools.ant.Task.perform(Task.java:348)
at org.apache.tools.ant.Target.execute(Target.java:390)
at org.apache.tools.ant.Target.performTasks(Target.java:411)
at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1360)
at org.apache.tools.ant.helper.SingleCheckExecutor?.executeTargets(Single CheckExecutor?.java:38)
at org.apache.tools.ant.Project.executeTargets(Project.java:1212)
at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:441)
at org.apache.tools.ant.UnknownElement?.execute(UnknownElement?.java:291)
at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl?.invoke(DelegatingMethodAcces? sorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:601)
at org.apache.tools.ant.dispatch.DispatchUtils?.execute(DispatchUtils?.jav a:106)
at org.apache.tools.ant.Task.perform(Task.java:348)
at org.apache.tools.ant.Target.execute(Target.java:390)
at org.apache.tools.ant.Target.performTasks(Target.java:411)
at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1360)
at org.apache.tools.ant.Project.executeTarget(Project.java:1329)
at org.apache.tools.ant.helper.DefaultExecutor?.executeTargets(DefaultExe? cutor.java:41)
at org.apache.tools.ant.Project.executeTargets(Project.java:1212)
at org.apache.tools.ant.Main.runBuild(Main.java:801)
at org.apache.tools.ant.Main.startAnt(Main.java:218)
at org.apache.tools.ant.launch.Launcher.run(Launcher.java:280)
at org.apache.tools.ant.launch.Launcher.main(Launcher.java:109)

Caused by: net.sf.launch4j.ExecException?: java.io.IOException: Cannot run progra m "/usr/src/i2p/i2p.i2p/installer/lib/launch4j/bin/windres": error=2, Datei oder Verzeichnis nicht gefunden

at net.sf.launch4j.Util.exec(Util.java:147)
at net.sf.launch4j.Cmd.exec(Builder.java:205)
at net.sf.launch4j.Builder.build(Builder.java:97)
… 29 more

Caused by: java.io.IOException: Cannot run program "/usr/src/i2p/i2p.i2p/install er/lib/launch4j/bin/windres": error=2, Datei oder Verzeichnis nicht gefunden

at java.lang.ProcessBuilder?.start(ProcessBuilder?.java:1029)
at java.lang.Runtime.exec(Runtime.java:615)
at java.lang.Runtime.exec(Runtime.java:483)
at net.sf.launch4j.Util.exec(Util.java:117)
… 31 more

Caused by: java.io.IOException: error=2, Datei oder Verzeichnis nicht gefunden

at java.lang.UNIXProcess.forkAndExec(Native Method)
at java.lang.UNIXProcess.<init>(UNIXProcess.java:135)
at java.lang.ProcessImpl?.start(ProcessImpl?.java:130)
at java.lang.ProcessBuilder?.start(ProcessBuilder?.java:1021)
… 34 more

Subtickets

Change History (2)

comment:1 Changed 8 years ago by killyourtv

Resolution: invalid
Status: newclosed

<eche|on> ha, ok, my fault
<eche|on> now it builds

"All's well that ends well." ;)

comment:2 Changed 8 years ago by Eche|on

Fixed with installing libc6-i386 and setting javac to java7 one.

Note: See TracTickets for help on using tickets.