Opened 8 years ago

Closed 6 years ago

#628 closed defect (fixed)

Allow IE to use regular themes

Reported by: zzz Owned by: killyourtv
Priority: minor Milestone: 0.9.7
Component: apps/console Version: 0.8.13
Keywords: themes Cc: killyourtv
Parent Tickets: Sensitive: no

Description

A couple years ago when we added theme support we put in logic to force IE to the classic theme as IE looked bad on the standard themes. Since then we have cleaned up compliance with HTML standards and there are new versions of IE.

So it seems like we should be able to modify things to allow IE versions > X (for some X) to use standard themes.

But kytv reports that even IE 9 looks terrible on standard themes. He speculates that maybe it's our use of CSS 3. But I didn't think we used much if any CSS 3.

So this ticket is for somebody to go through our CSS/HTML and try to tweak it so that a recent version of IE will look decent on the standard themes. Then update the force logic appropriately. If possible and not that much work. Otherwise forget it.

Subtickets

Change History (6)

comment:1 Changed 8 years ago by killyourtv

The 'shimmed' theme looks pretty bad in IE too. Maybe it could be made to look 'less crappy', but I have my doubts about it being worth it.

It may not be caused by CSS3, of course, but IE used to be notoriously bad at supporting standards, and even worse at supporting CSS3. IE9 is supposed to be "better" (whatever that means).

If you validate the CSS at w3c it'll flag 332 "errors". "Errors" (in quotes) because they can be grouped into the following categories:

  • CSS3 that it recognizes
  • CSS3 that it doesn't recognize
  • Mozilla specific selectors
  • WebKit? specific selectors

They're not really errors, you see.

If this could be done easily, fine…but I think it'd more pain than it's worth.

comment:2 Changed 8 years ago by zzz

Priority: minormajor

New split installer reveals stats on our new users http://code.google.com/p/i2p/downloads/list - 7:1 Windows:Non-win. Yet I don't regularly use or test on Windows and I don't have anything newer than XP in the house.

We need to increase our attention and development for Win / IE. Ideally we could get a new dev to work on it. Given the new info on Win usage and the general crappiness of the classic theme I'm bumping this to Major for now, to see if anybody will bite.

comment:3 Changed 7 years ago by zzz

Milestone: 0.9.30.9.9
Priority: majorminor

nobody bit.

comment:4 Changed 7 years ago by zzz

Milestone: 0.9.90.9.6
Owner: set to killyourtv
Status: newassigned

Looks like IE 10 will work. See ticket #900

comment:5 Changed 7 years ago by str4d

Keywords: themes added

comment:6 Changed 6 years ago by zzz

Milestone: 0.9.60.9.7
Resolution: fixed
Status: assignedclosed

fixed by kytv in 0.9.7

Note: See TracTickets for help on using tickets.