Opened 7 years ago

Closed 4 years ago

#637 closed enhancement (fixed)

snark sort algo ignoring ¨The.¨

Reported by: DISABLED Owned by: zzz
Priority: trivial Milestone: 0.9.23
Component: apps/i2psnark Version: 0.9
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

Sort algo appears to skew search results by ignoring torrents starting with "The.". eg "The.Shining" is sorted with the S determining position.

Subtickets

Change History (15)

comment:1 Changed 7 years ago by zzz

Resolution: not a bug
Status: newclosed

That's an intentional feature.

comment:2 Changed 7 years ago by DISABLED

Resolution: not a bug
Status: closedreopened

The sorting algorithm is arbitrary, not communicated to the user at all, filters out "the" but not "a", is specific to a single language when Snark itself is supported in many languages (why not filter out el, la, etc?), and as such is confusing and unhelpful. If this is an intentional feature, it's a joke. Please fix, or at least make a better argument for retaining this so-called "feature".

comment:3 Changed 7 years ago by DISABLED

Milestone: 0.9.10.9.3
Priority: minorblocker

comment:4 Changed 7 years ago by zzz

Milestone: 0.9.3
Priority: blockerminor
Resolution: not a bug
Status: reopenedclosed

comment:5 Changed 7 years ago by DISABLED

Milestone: 0.9.4
Resolution: not a bug
Status: closedreopened

No, seriously, it is a bug, or at the very least an undocumented quirk that really is poorly implemented and language specific. Just declaring it a feature without explanation is unsatisfactory, and repeatedly closing it on that basis without any attempt to shed light on the underlying thinking behind the feature is more unsatisfactory, still.

comment:6 Changed 7 years ago by zzz

mystery OP identified:

Nov 12 18:14:56 <dr|z3d> topiltzin: I'd welcome direct feedback on my updated bug reporting.. I'm trying to be diplomatic.. I notice another bug (feature request) I posted has now been picked up by zzz..
Nov 12 18:15:06 <topiltzin> which ticket dr|z3d ?
Nov 12 18:15:08 <dr|z3d> http://trac.i2p2.i2p/ticket/637
Nov 12 18:15:24 <dr|z3d> that's the ongoing ping pong game I seem to be playing with zzz.
Nov 12 18:15:41 <topiltzin> much better than your first comment
Nov 12 18:15:59 <topiltzin> 'unsatisfactory' == diplomatic. 'joke' != diplomatic
Nov 12 18:16:26 <topiltzin> I'm honored that you asked my opinion btw
Nov 12 18:16:29 <topiltzin> it means a lot
Nov 12 18:16:38 <dr|z3d> Good, then your coaching is working. Carry on ;)

comment:7 Changed 7 years ago by Zlatin Balevsky

And those of us foolish enough to believe this whole thing actually was about writing open-source software are feeling quite disgusted by both sides right now. Since I'm obviously playing Joe Average, let me tell you - both sides need to do some serious soul searching or I will just stop giving a damn.

The following expresses my sentiment perfectly because it compiles cleanly and evaluates to TRUE:

<dr|z3d> and if you make an issue out of who filed the bug (in good faith), then you're not responding in good faith. you're responding in bad faith, and undermining your own credibility in doing so.

Source: http://pastethis.i2p/show/2413

comment:8 in reply to:  1 Changed 7 years ago by Meeh

Type: defectenhancement

Replying to zzz:

That's an intentional feature.

I agree. We should look at the possibility to have a "locale" settings, see it at a possible feature/improvement, not a bug.
I'm moving this to a enhancement, since it's not a bug. But rather a feature that will make some in the world happy.

Also, I don't take any sides here. But I agree that it should not be a issue who filed the ticket as long as it's a valid ticket, and not spam or something else.

comment:9 Changed 7 years ago by zzz

Not making an issue of it, not sure how anybody took my 3-word comment otherwise. Just nice to attach some sort of identity to a commenter, especially one that is not "diplomatic" (quoting topiltzin). Also to know who I am playing "ping pong" (quoting drz) with, and that I am playing a game at all.

My responses at comments 1 and 4 above were in "good faith" (quoting drz) and made without knowledge of the OP's identity.

Just trying to focus on open-source software (which includes handling tickets), as zab says.

comment:10 Changed 6 years ago by str4d

Milestone: 0.9.4

comment:11 Changed 6 years ago by zzz

Priority: minortrivial

comment:12 Changed 5 years ago by zzz

related: #1303

comment:13 in reply to:  12 ; Changed 5 years ago by backup

I think this ticket (#637) is about, how intelligent is the sort algo and does it cover all languages?
In my opinion it's not related to #1303
BR backup

comment:14 in reply to:  13 Changed 5 years ago by backup

A solution could be a language specific list for ignoring leading words:

EN: The The. The_ The- A._- …
DE: Der._- Die._- Das._- Ein._- …
ESP: ?
RU: ?

comment:15 Changed 4 years ago by zzz

Milestone: 0.9.23
Resolution: fixed
Status: reopenedclosed

see #1303 for resolution

Note: See TracTickets for help on using tickets.