Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#656 closed defect (fixed)

Uninstaller hangs in Windows 7

Reported by: mohsen Owned by:
Priority: major Milestone: 0.9.1
Component: installer Version: 0.9
Keywords: uninstall, windows Cc:
Parent Tickets:

Description

Hi there. I tried out i2p a couple of months ago, and I've tried to uninstall it several times since (I'm on Windows 7 x64.) The trouble is, the uninstaller simply appears to not do anything. I hit uninstall, with or without the "Force deletion" box ticked, click uninstall, and.. nothing. It'll sit there, uninstalling, but to all appearances, doing nothing for hours. I've tried disabling, and stopping the I2P service beforehand.

Subtickets

Change History (3)

comment:1 Changed 6 years ago by killyourtv

  • Component changed from unspecified to installer
  • Keywords uninstall windows added
  • Priority changed from critical to minor
  • Resolution set to fixed
  • Status changed from new to closed

I checked in a fix for this which will be in new installations as of 0.9.1-13.

To work around it you can open uninstall_i2p_service_winnt.bat and remove the two lines at the bottom

if "%2"=="--nopause" goto :eof
pause

The Izpack config file had the following set:

            <executable targetfile="$INSTALL_PATH/uninstall_i2p_service_winnt.bat" stage="uninstall" os="windows">
                <args>
                    <arg value="$INSTALL_PATH\wrapper.config" />
                    <arg value="--nopause" />
                </args>
            </executable>

That worked in Windows XP but apparently not in Windows 7.

comment:2 Changed 6 years ago by killyourtv

  • Summary changed from uninstall i2p to Uninstaller hangs in Windows 7

comment:3 Changed 6 years ago by killyourtv

  • Priority changed from minor to major
Note: See TracTickets for help on using tickets.