Opened 7 years ago

Closed 7 years ago

#687 closed defect (fixed)

Error evaluating profiles NullPointerException 0.9.1-6, on android

Reported by: sponge Owned by: zzz
Priority: minor Milestone: 0.9.2
Component: router/netdb Version: 0.9.1
Keywords: NullPointerException Cc:
Parent Tickets: Sensitive: no

Description

CRIT  [leTimer2 4/4] router.peermanager.PeerManager: Error evaluating profiles
java.lang.NullPointerException
        at gnu.crypto.prng.BasePRNGStandalone.nextByteInternal(BasePRNGStandalone.java:165)
        at gnu.crypto.prng.BasePRNGStandalone.nextByte(BasePRNGStandalone.java:108)
        at net.i2p.util.FortunaRandomSource.nextBits(FortunaRandomSource.java:207)
        at net.i2p.util.FortunaRandomSource.signedNextInt(FortunaRandomSource.java:101)
        at net.i2p.util.FortunaRandomSource.nextInt(FortunaRandomSource.java:71)
        at net.i2p.router.peermanager.CapacityCalculator.calc(CapacityCalculator.java:61)
        at net.i2p.router.peermanager.PeerProfile.calculateCapacity(PeerProfile.java:526)
        at net.i2p.router.peermanager.PeerProfile.coalesceStats(PeerProfile.java:517)
        at net.i2p.router.peermanager.ProfileOrganizer.reorganize(ProfileOrganizer.java:806)
        at net.i2p.router.peermanager.PeerManager$Reorg.timeReached(PeerManager.java:93)
        at net.i2p.util.SimpleTimer2$TimedEvent.run(SimpleTimer2.java:268)
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:442)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:305)
        at java.util.concurrent.FutureTask.run(FutureTask.java:137)
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:150)
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:264)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1076)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:569)
        at java.lang.Thread.run(Thread.java:856)

Subtickets

Change History (1)

comment:1 Changed 7 years ago by zzz

Resolution: fixed
Status: newclosed

Caused by static context ref in CapacityCalculator?. Would only happen in Android, after router restart in same JVM. Not new in -6.

fixed in 0.9.1-7. I also changed PRNG to throw a more descriptive exception than NPE.

Note: See TracTickets for help on using tickets.