Opened 7 years ago

Closed 6 years ago

#739 closed enhancement (wontfix)

Rate Scheduling

Reported by: DISABLED Owned by: zzz
Priority: minor Milestone: 0.9.9
Component: router/transport Version: 0.9.2
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

I2P has the potential to be quite a bandwidth hog, and for those of us with transfer caps who would like to participate in the network, it is very annoying to have to start and stop the router depending on the time of day. many torrent clients have functionality to allow you to configure the bandwidth allocation at different times, as you see fit. along this line i propose some sort of rate scheduler, possibly on a per tunnel basis, to allow torrenting to be slowed during certain times, while still allowing your eepsite to remain at full speed. you would be able to set rate limits, and a transfer cap per month or week in addition. i for one would make myself availiable as a router more if such functionality were addd, and i would imagine others are in a similar situation.

Subtickets

Change History (5)

comment:1 Changed 7 years ago by zzz

Component: wrapperrouter/transport
Milestone: 0.9.30.9.6
Owner: set to zzz

Working on per-client priorities which would help a little.

Any pointers to apps that you think do rate scheduling well? Screenshot maybe?

This isn't _that_ hard to do, and it's been brought up many times before. But as a configuration option that would be used by few people, and probably an intimidating config page for it, it's been low priority. In fact, there's so much other stuff to do, anything that is not enabled by default, I don't have time for at all.

But hey, somebody may want to work on it.

comment:2 Changed 7 years ago by DISABLED

Most of the torrent clients i've ever used have some sort of rate limiting, but i'd say the best would have these functions:

  • differing bandwidth limits based on time of day (most torrent clients)
  • click-to-change from 'fast' to 'slow', based on preconfigured bandwidth limits (qbittorrent)
  • maximum (download/upload/total tranfer) per (day/week/month), seperate from the bandwidth limits
  • seperate caps for participating tunnels and client tunnels, maybe a hard to find option? ;)

comment:3 Changed 7 years ago by str4d

#767 is a duplicate of this. zzz suggested there implementing this as a plugin.

comment:4 Changed 7 years ago by zzz

Milestone: 0.9.60.9.9

comment:5 Changed 6 years ago by zzz

Resolution: wontfix
Status: newclosed

New "I2Cron" plugin at

http://bitbucket.i2p/ or http://l32phaa2pum674gwkj2sjfjf256kl3scwczbhs3ext3y4elqthua.b32.i2p/ or http://plugins.i2p/

Not tested or reviewed by me. But we clearly aren't going to do this in the router, and with the plugin out there, I'm closing this ticket.

Note: See TracTickets for help on using tickets.