Opened 6 years ago

Closed 6 years ago

#757 closed defect (fixed)

http local tunnel auth unable to be none

Reported by: guest Owned by:
Priority: minor Milestone: 0.9.4
Component: apps/i2ptunnel Version: 0.9.3
Keywords: Cc:
Parent Tickets:

Description

I2P 0.9.3-1
Setting a user/pass on local auth works fine, problem is when unsetting it, the tunnel still says auth is required.

Subtickets

Attachments (3)

2012-10-30-133642_717x396_scrot.png (27.0 KB) - added by guest 6 years ago.
chromium-20.png (24.1 KB) - added by zzz 6 years ago.
2012-10-31-132702_1024x600_scrot.png (77.9 KB) - added by guest 6 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 6 years ago by guest

  • Component changed from unspecified to apps/i2ptunnel
  • Priority changed from minor to major

comment:2 Changed 6 years ago by zzz

I can't reproduce this here.

Please uncheck enable, save, verify it is still requiring auth, then copy all the lines from ~/.i2p/i2ptunnel.config starting with "tunnel.0" here. Check for any plaintext or md5 passwords and xxxxx them out before copying if you wish.

Changed 6 years ago by guest

comment:3 Changed 6 years ago by guest

  • Priority changed from major to minor

OK i see the problem now from what you mentioned. The issue is that i am seeing no checkbox to enable/disable (though i do in the source)
<input value="1" type="checkbox" id="outproxyAuth" name="outproxyAuth" title="Check if the outproxy requires authorization" class="tickbox" />

My browser is chromium v22

comment:4 Changed 6 years ago by zzz

In firefox the boxes are there.
In Chromium for me, the enable box is between the username and password boxes, but you have to click to the left of the username box to "click" the enable box. Very strange.

Changed 6 years ago by zzz

comment:5 Changed 6 years ago by guest

for reference, the checkbox's render with firefox perfectly here too
I am not a visual style guy so this is my attempt at debugging.
attached might be a clue to the chromium defect? Width positioning of the checkbox which is underneath the inputbox.

Changed 6 years ago by guest

comment:6 Changed 6 years ago by zzz

found it, fix will be in 0.9.3-4

comment:7 Changed 6 years ago by zzz

Fixed in 0.9.3-4. Thanks for the report.

comment:8 Changed 6 years ago by zzz

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.