Opened 7 years ago

Closed 7 years ago

#759 closed defect (fixed)

debian package version numbers are wrong

Reported by: guest Owned by: killyourtv
Priority: trivial Milestone: 0.9.4
Component: package/debian Version: 0.9.3
Keywords: version number Cc:
Parent Tickets:

Description

when building i2p with the following command:

ant debian

everything builds correctly, however the versions of the .deb files are set to be 0.9.1, even though I'm using 0.9.3.

When i install the .deb files and launch i2p, the console page tells me that the version that is running is 0.9.3-0-deb1, as expected.

Subtickets

Change History (2)

comment:1 Changed 7 years ago by zzz

  • Status changed from new to assigned

comment:2 Changed 7 years ago by killyourtv

  • Resolution set to fixed
  • Status changed from assigned to closed

ant debian shows:

debian-binary:
     [echo] Did you update the version using dch -i?
     [echo]  
     [echo] If the changelog was not updated with dch -i, press
     [echo] press CTRL+C to abort building this Debian package.
     [echo] 
     [echo] Pausing build for ten seconds to give enough time to read this notice

...and I suppose you didn't update the changelog.

In any case I updated the changelog file around the time of release. It will show 0.9.3 if you pull from mtn. (the version number is stored in debian/changelog)

Note: See TracTickets for help on using tickets.