Opened 9 years ago

Closed 9 years ago

#76 closed defect (fixed)

Pipe closed / UPnP timeout / SYN with wrong IDs

Reported by: anonymous Owned by: zzz
Priority: minor Milestone: 0.8.3
Component: router/transport Version: 0.8.1
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

18:56:26.640 FEHLER [NotifySocket?] org.cybergarage.util.Debug : org.cybergarage.xml.ParserException?: java.net.SocketTimeoutException?: connect timed out at org.cybergarage.xml.Parser.parse(Parser.java:65) at org.cybergarage.upnp.ControlPoint?.addDevice(ControlPoint?.java:228) at org.cybergarage.upnp.ControlPoint?.notifyReceived(ControlPoint?.java:477) at org.cybergarage.upnp.ssdp.SSDPNotifySocket.run(SSDPNotifySocket.java:112) at java.lang.Thread.run(Unknown Source) Caused by: java.net.SocketTimeoutException?: connect timed out at java.net.PlainSocketImpl?.socketConnect(Native Method) at java.net.PlainSocketImpl?.doConnect(Unknown Source) at java.net.PlainSocketImpl?.connectToAddress(Unknown Source) at java.net.PlainSocketImpl?.connect(Unknown Source) at java.net.SocksSocketImpl?.connect(Unknown Source) at java.net.Socket.connect(Unknown Source) at sun.net.NetworkClient?.doConnect(Unknown Source) at sun.net.www.http.HttpClient?.openServer(Unknown Source) at sun.net.www.http.HttpClient?.openServer(Unknown Source) at sun.net.www.http.HttpClient?.(Unknown Source) at sun.net.www.http.HttpClient?.New(Unknown Source) at sun.net.www.http.HttpClient?.New(Unknown Source) at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(Unknown Source) at sun.net.www.protocol.http.HttpURLConnection.plainConnect(Unknown Source) at sun.net.www.protocol.http.HttpURLConnection.connect(Unknown Source) at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source) at org.cybergarage.xml.Parser.parse(Parser.java:55) … 4 more
18:56:26.640 FEHLER [NotifySocket?] org.cybergarage.util.Debug : NOTIFY * HTTP/1.1 Host:239.255.255.250:1900 NT:upnp:rootdevice NTS:ssdp:alive Location:http://192.168.2.100:2869/upnphost/udhisapi.dll?content=uuid:a8420979-3a0b-4a21-ae28-37221416c0f5 USN:uuid:a8420979-3a0b-4a21-ae28-37221416c0f5::upnp:rootdevice Cache-Control:max-age=900 Server:Microsoft-Windows-NT/5.1 UPnP/1.0 UPnP-Device-Host/1.0 OPT:"http://schemas.upnp.org/upnp/1/0/"; ns=01 01-NLS:5b0902ae924b6316d1e8bf74fe5ac24c
18:56:23.640 FEHLER [NotifySocket?] org.cybergarage.util.Debug : org.cybergarage.xml.ParserException?: java.net.SocketTimeoutException?: connect timed out at org.cybergarage.xml.Parser.parse(Parser.java:65) at org.cybergarage.upnp.ControlPoint?.addDevice(ControlPoint?.java:228) at org.cybergarage.upnp.ControlPoint?.notifyReceived(ControlPoint?.java:477) at org.cybergarage.upnp.ssdp.SSDPNotifySocket.run(SSDPNotifySocket.java:112) at java.lang.Thread.run(Unknown Source) Caused by: java.net.SocketTimeoutException?: connect timed out at java.net.PlainSocketImpl?.socketConnect(Native Method) at java.net.PlainSocketImpl?.doConnect(Unknown Source) at java.net.PlainSocketImpl?.connectToAddress(Unknown Source) at java.net.PlainSocketImpl?.connect(Unknown Source) at java.net.SocksSocketImpl?.connect(Unknown Source) at java.net.Socket.connect(Unknown Source) at sun.net.NetworkClient?.doConnect(Unknown Source) at sun.net.www.http.HttpClient?.openServer(Unknown Source) at sun.net.www.http.HttpClient?.openServer(Unknown Source) at sun.net.www.http.HttpClient?.(Unknown Source) at sun.net.www.http.HttpClient?.New(Unknown Source) at sun.net.www.http.HttpClient?.New(Unknown Source) at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(Unknown Source) at sun.net.www.protocol.http.HttpURLConnection.plainConnect(Unknown Source) at sun.net.www.protocol.http.HttpURLConnection.connect(Unknown Source) at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source) at org.cybergarage.xml.Parser.parse(Parser.java:55) … 4 more
18:56:23.640 FEHLER [NotifySocket?] org.cybergarage.util.Debug : NOTIFY * HTTP/1.1 Host:239.255.255.250:1900 NT:upnp:rootdevice NTS:ssdp:alive Location:http://192.168.2.100:2869/upnphost/udhisapi.dll?content=uuid:a8420979-3a0b-4a21-ae28-37221416c0f5 USN:uuid:a8420979-3a0b-4a21-ae28-37221416c0f5::upnp:rootdevice Cache-Control:max-age=900 Server:Microsoft-Windows-NT/5.1 UPnP/1.0 UPnP-Device-Host/1.0 OPT:"http://schemas.upnp.org/upnp/1/0/"; ns=01 01-NLS:5b0902ae924b6316d1e8bf74fe5ac24c
17:01:25.660 FEHLER [2CP Writer 9] .client.ClientConnectionRunner?: IO exception sending I2CP message: java.io.IOException: Pipe closed
16:47:08.879 FEHLER [2CP Writer 5] .client.ClientConnectionRunner?: IO exception sending I2CP message: java.io.IOException: Pipe closed
15:37:27.214 FEHLER [2CP Writer 4] .client.ClientConnectionRunner?: IO exception sending I2CP message: java.io.IOException: Pipe closed
13:20:20.707 FEHLER [otifier 2u88] client.streaming.PacketHandler?: Received a syn with the wrong IDs, con=[Connection atcHfg==/wUCdVQ== from aUQa up 3m wsize: 1 cwin: 1 rtt: 8000 rto: 12000 unacked out: 1 unacked in: 0 sent: 1 rcvd: 1 maxWin 128 MTU 1730] packet=atcHfg==mwa1lw==: #0 DELAY 0 FROM MS 1730 SIG SYN ACK 0
12:32:53.144 FEHLER [otifier XPaJ] client.streaming.PacketHandler?: Received a syn with the wrong IDs, con=[Connection tHv0XA==/6hqM-g== to im9g up 50s wsize: 3 cwin: 4 rtt: 7968 rto: 28996 unacked out: 0 unacked in: 0 reset received 35s ago close sent 35s ago close received 33s ago sent: 2 rcvd: 1 maxWin 128 MTU 1730] packet=tHv0XA==PQszlg==: #0 CLOSE DELAY 2000 FROM MS 1730 SIG SYN ACK 0 data: 280
12:32:28.676 FEHLER [otifier XPaJ] client.streaming.PacketHandler?: Received a syn with the wrong IDs, con=[Connection tHv0XA==/6hqM-g== to im9g up 26s wsize: 3 cwin: 4 rtt: 7968 rto: 28996 unacked out: 0 unacked in: 0 close sent 11s ago close received 9s ago sent: 2 rcvd: 1 maxWin 128 MTU 1730] packet=tHv0XA==PQszlg==: #0 CLOSE DELAY 1000 FROM MS 1730 SIG SYN ACK 0 data: 280

Subtickets

Change History (3)

comment:1 Changed 9 years ago by zzz

Owner: set to zzz
Priority: majorminor
Status: newassigned
Summary: bugsPipe closed / UPnP timeout / SYN with wrong IDs

3 separate things here:

1) pipe closed, caused by app going away, we have many other tickets with this

2) UPnP timeout, harmless, at least one other ticket… maybe we need to extend the socket timeout for the NOTIFY socket

3) SYN with wrong IDs, also harmless, but really don't know the cause, it's been around forever

comment:2 Changed 9 years ago by zzz

Component: api/datarouter/transport
Milestone: 0.8.3
Version: 0.8.1

#1 and #3 changed to WARN in 0.8.1-17. Changing component to router/transport for #2.

comment:3 Changed 9 years ago by zzz

Resolution: fixed
Status: assignedclosed

All UPnP errors changed to warnings in 0.8.3

Note: See TracTickets for help on using tickets.