Opened 9 years ago

Closed 9 years ago

#77 closed defect (fixed)

I2CP pipe closed errors (was: always trackerbugs)

Reported by: anonymous Owned by: zzz
Priority: minor Milestone: 0.8.2
Component: api/i2cp Version: 0.8
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

21:00:00.166 FEHLER [CP Writer 14] .client.ClientConnectionRunner?: IO exception sending I2CP message: java.io.IOException: Pipe closed
20:58:45.009 FEHLER [CP Writer 13] .client.ClientConnectionRunner?: IO exception sending I2CP message: java.io.IOException: Pipe closed
19:31:30.703 FEHLER [cheduler 4/4] net.i2p.util.ByteCache? : WARNING: Low memory, clearing byte caches
19:05:38.086 FEHLER [2CP Writer 9] .client.ClientConnectionRunner?: IO exception sending I2CP message: java.io.IOException: Pipe closed
19:04:21.774 FEHLER [2CP Writer 7] .client.ClientConnectionRunner?: IO exception sending I2CP message: java.io.IOException: Pipe closed
17:57:33.503 FEHLER [2CP Writer 6] .client.ClientConnectionRunner?: IO exception sending I2CP message: java.io.IOException: Pipe closed
17:56:32.316 FEHLER [2CP Reader 4] ent.ClientMessageEventListener?: Error occurred net.i2p.data.DataFormatException?: Not enough bytes for the field at net.i2p.data.DataHelper?.readLong(DataHelper?.java:402) at net.i2p.data.i2cp.SessionId?.readBytes(SessionId?.java:41) at net.i2p.data.i2cp.DestroySessionMessage?.doReadMessage(DestroySessionMessage?.java:44) at net.i2p.data.i2cp.I2CPMessageImpl.readMessage(I2CPMessageImpl.java:74) at net.i2p.data.i2cp.I2CPMessageHandler.readMessage(I2CPMessageHandler.java:45) at net.i2p.data.i2cp.I2CPMessageReader$I2CPMessageReaderRunner.run(I2CPMessageReader.java:153) at java.lang.Thread.run(Unknown Source) at net.i2p.util.I2PThread.run(I2PThread.java:77) net.i2p.data.i2cp.I2CPMessageException: Unable to load the message data at net.i2p.data.i2cp.DestroySessionMessage?.doReadMessage(DestroySessionMessage?.java:46) at net.i2p.data.i2cp.I2CPMessageImpl.readMessage(I2CPMessageImpl.java:74) at net.i2p.data.i2cp.I2CPMessageHandler.readMessage(I2CPMessageHandler.java:45) at net.i2p.data.i2cp.I2CPMessageReader$I2CPMessageReaderRunner.run(I2CPMessageReader.java:153) at java.lang.Thread.run(Unknown Source) at net.i2p.util.I2PThread.run(I2PThread.java:77)
17:56:32.316 FEHLER [ent Writer 2] net.i2p.client.I2PSessionImpl2: [1247]: cause java.io.IOException: Pipe closed at java.io.PipedInputStream?.checkStateForReceive(Unknown Source) at java.io.PipedInputStream?.receive(Unknown Source) at java.io.PipedOutputStream?.write(Unknown Source) at java.io.OutputStream?.write(Unknown Source) at net.i2p.data.i2cp.I2CPMessageImpl.writeMessage(I2CPMessageImpl.java:112) at net.i2p.client.ClientWriterRunner?.run(ClientWriterRunner?.java:69) at java.lang.Thread.run(Unknown Source) at net.i2p.util.I2PThread.run(I2PThread.java:77)
17:56:32.316 FEHLER [ent Writer 2] net.i2p.client.I2PSessionImpl2: [1247]: Error occurred: Error writing out the message - Pipe closed
15:59:50.286 FEHLER [cheduler 2/4] net.i2p.util.ByteCache? : WARNING: Low memory, clearing byte caches

Subtickets

Change History (4)

comment:1 Changed 9 years ago by zzz

Owner: set to zzz
Priority: majorminor
Status: newassigned

I don't know what 'always trackerbugs' means.

Pipe closed errors are probably caused by stopping applications. Maybe they shouldn't be ERRORs, just WARNs instead. There's a lot more of them in #78.

comment:2 Changed 9 years ago by zzz

Summary: always trackerbugsI2CP pipe closed errors (was "always trackerbugs")

comment:4 Changed 9 years ago by zzz

Summary: I2CP pipe closed errors (was "always trackerbugs")I2CP pipe closed errors (was: always trackerbugs)
Version: 0.8

comment:5 Changed 9 years ago by zzz

Component: api/dataapi/i2cp
Milestone: 0.8.2
Resolution: fixed
Status: assignedclosed

Changed from error to warning in 0.8.1-17.

Note: See TracTickets for help on using tickets.