Opened 7 years ago

Closed 5 years ago

#771 closed defect (fixed)

I2PSnark: Willful rewriting of special characters

Reported by: DISABLED Owned by: zzz
Priority: minor Milestone: 0.9.15
Component: apps/i2psnark Version: 0.9.3
Keywords: special character Cc:
Parent Tickets: Sensitive: no

Description

Screenshot (assembly): http://zerofiles.i2p/i2p/97c7187597b66f3e34a68a5ce533a6dca3b7819c.html

I mean, the client should behave in principle neutral towards special characters. For such cases, there is already Unicode.

(Ich meine, der Klient sollte sich prinzipiell neutral gegenüber Sonderzeichen verhalten. Für solche Fälle gibt es bereits Unicode.)

I2P version: 0.9.*
Platform: Linux

Subtickets

#1132: New per-torrent config system for i2psnarkclosedzzz

Change History (6)

comment:1 Changed 7 years ago by DISABLED

Addendum. This time Snark created the torrent. In the torrent file, the file name with a question mark is embedded right also. But with the Snark open this file will not be recognized as belonging and instead a 0-byte, with an underscore instead of a question mark, referred to as "Complete". Thus, the confusion is also complete.

(Nachtrag. Dieses Mal erstellte Snark selbst den Torrent. In der Torrent-Datei wird der Dateiname mit Fragezeichen richtig auch eingebettet. Aber beim öffnen mit Snark wird diese Datei nicht als zugehörig erkannt und stattdessen eine 0-Byte große, mit Unterstrich statt Fragezeichen, als "Complete" bezeichnet. Damit ist die Verwirrung ebenfalls komplett.)

comment:2 Changed 7 years ago by zzz

Related to / possible duplicate of #571

comment:3 Changed 7 years ago by str4d

Milestone: 0.9.4

comment:4 Changed 6 years ago by zzz

Add a subticket #1132.

comment:5 Changed 5 years ago by zzz

Milestone: 0.9.15
Status: newaccepted

comment:6 Changed 5 years ago by zzz

Resolution: fixed
Status: acceptedclosed

fixed in e8883e85a7761bbda9df59b3f6b57601cc01bb5a 0.9.1.14-7 by disabling mapping on torrents that were created locally, and storing that setting in the new per-torrent config files. This is the simplest fix as we don't have to remember per-file mappings, or design some sort of reversible mapping, which probably wasn't possible anyway.

Note: See TracTickets for help on using tickets.