Opened 7 years ago

Closed 2 years ago

#779 closed defect (not a bug)

increase server max threads or i2ptunnel.blockingHandlerCount

Reported by: Eche|on Owned by:
Priority: minor Milestone:
Component: apps/i2ptunnel Version: 0.9.3
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

Hi!

On 0.9.3-6 I get a lot of these:
increase server max threads or i2ptunnel.blockingHandlerCount

although for that destination I set Max concurrent connection=0.
Is there a hardcoded limit?

echelon

Subtickets

Change History (7)

comment:1 Changed 7 years ago by zzz

Component: unspecifiedapps/i2ptunnel

This is in i2ptunnel, unrelated to the streaming connection limit.

There's a max number of threads ("blocking handlers") that will be created to do some initial processing and deal with the connection setup to the external server when a connection comes in. This helps prevent somebody from clogging up your JVM with threads. There's a separate pool for each server. The default max is 65. Normally it all happens fast and these threads don't stick around long.

If you get a huge burst and it starts dropping incoming conns, you will get this message. Could also be a slowloris. But the most likely explanation is some thread or connection limit in the external server. Once the external server starts queueing connections due to some limit or lack of processing time, the number of blocking handlers sitting around waiting for the external server will grow quickly and hit the limit. This is really bad as it results in dropped conns, or long connect times even if below the limit.

Hence the message. Check the limits on your external server, or add i2ptunnel.blockingHandlerCount=nnn in i2ptunnel custom options.

comment:2 Changed 7 years ago by zzz

possibly related: #819

comment:3 Changed 6 years ago by str4d

Keywords: test added
Milestone: 0.9.4

comment:8 Changed 6 years ago by str4d

Keywords: testing-needed added; test removed

comment:9 Changed 6 years ago by str4d

Keywords: testing-needed removed
Status: newinfoneeded_new

comment:10 Changed 2 years ago by zzz

Status: infoneeded_newnew

wrong status

comment:11 Changed 2 years ago by zzz

Resolution: not a bug
Status: newclosed
Note: See TracTickets for help on using tickets.