Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#791 closed defect (fixed)

The button "New" (Write new mail) is absent in router bote-mail page if the Russian language of GUI is selected

Reported by: guest Owned by: HungryHobo
Priority: major Milestone: 0.9.4
Component: apps/plugins Version: 0.9.3
Keywords: bote Cc:
Parent Tickets:

Description

The button "New" (Write new mail) is absent in router bote-mail page if the Russian language of GUI is selected. Please, fix this.

Subtickets

Attachments (1)

i2pbote-ru.png (7.9 KB) - added by HungryHobo 6 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 6 years ago by zzz

  • Component changed from unspecified to apps/plugins
  • Owner set to HungryHobo
  • Status changed from new to assigned

Changed 6 years ago by HungryHobo

comment:2 Changed 6 years ago by HungryHobo

Looks good in FF 17 and Chromium 22 using I2P-Bote build 0.2.6-b104 which was released earlier today (see attachment). I also tried the latest build from plugins.i2p (-b103) which also showed the button. Are you running an older build?

The iframe should probably be a little bigger for Russian, though, because there is more text.

comment:3 Changed 6 years ago by zzz

@HH

FYI I recently merged this change from asaf@…: http://stats.i2p/cgi-bin/viewmtn/revision/info/ec0ec8bca6aa7c8d6b314688662891ed0c80aa34
ec0ec8bca6aa7c8d6b314688662891ed0c80aa34

which I think is related to this ticket? Or maybe not...

The change was a problem due to a monotone bug triggered by a timestamp added by guitone. See the merge checkin comment for details: http://stats.i2p/cgi-bin/viewmtn/revision/info/7c4c9f3ad780fc11f521265819b35b34772a22d3
7c4c9f3ad780fc11f521265819b35b34772a22d3

Also fixed compilation for Java 6 with a Java 7 SDK.

comment:4 Changed 6 years ago by HungryHobo

Thanks, zzz. It looks like Monotone still doesn't like the revision, though. Is there a way to edit an existing revision and fix the timestamp? I'm guessing no. Maybe the next version of Monotone will fix it.

comment:5 Changed 6 years ago by HungryHobo

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:6 Changed 6 years ago by zzz

It appeared from their mailing list late last year that they were headed for a release after a year and a half. http://lists.nongnu.org/archive/html/monotone-devel/ although things are moving very slowly.

I've tried to bump the priority of the problem, but no action so far.

You should be able to fix the problem locally with

REV=ec0ec8bca6aa7c8d6b314688662891ed0c80aa34
mtn local kill_certs $REV date
mtn cert $REV date 2012-01-01T00:00:00

or maybe just
mtn local kill_revision $REV

but of course the bad cert comes back when you sync.

I think things were busted as soon as he checked it in but sorry if I made the problem worse by merging it.

Note: See TracTickets for help on using tickets.