Opened 9 years ago

Closed 9 years ago

#80 closed defect (fixed)

NTCP RejectedExecution / Pipe Closed / SSU Output Queue Error

Reported by: anonymous Owned by: zzz
Priority: minor Milestone: 0.8.2
Component: router/transport Version: 0.8.1
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

I2P version: 0.8-0
Java version: Sun Microsystems Inc. 1.6.0_21 (Java™ SE Runtime Environment 1.6.0_21-b06)
Platform: Windows XP x86 5.1
Processor: uninitialized (pentium3)
Jbigi: Locally optimized native BigInteger? library loaded from the library path
Encoding: Cp1252

Berichte der Kritischen Ereignisse
16:52:11.709 KRITISCH [NTCP Pumper ] ter.transport.ntcp.EventPumper?: Error in the event pumper java.util.concurrent.RejectedExecutionException? at java.util.concurrent.ThreadPoolExecutor?$AbortPolicy?.rejectedExecution(Unknown Source) at java.util.concurrent.ThreadPoolExecutor?.reject(Unknown Source) at java.util.concurrent.ThreadPoolExecutor?.execute(Unknown Source) at net.i2p.router.transport.ntcp.NTCPSendFinisher.add(NTCPSendFinisher.java:50) at net.i2p.router.transport.ntcp.NTCPTransport.sendComplete(NTCPTransport.java:342) at net.i2p.router.transport.ntcp.NTCPConnection.removeWriteBuf(NTCPConnection.java:911) at net.i2p.router.transport.ntcp.EventPumper?.processWrite(EventPumper?.java:537) at net.i2p.router.transport.ntcp.EventPumper?.processKeys(EventPumper?.java:287) at net.i2p.router.transport.ntcp.EventPumper?.run(EventPumper?.java:131) at java.lang.Thread.run(Unknown Source) at net.i2p.util.I2PThread.run(I2PThread.java:77)
Router Berichte (ändere)
Ort der Datei: C:\Programme\i2p\logs\log-router-0.txt

17:42:31.741 FEHLER [CP Writer 28] .client.ClientConnectionRunner?: IO exception sending I2CP message: java.io.IOException: Pipe closed
17:40:41.334 FEHLER [CP Writer 25] .client.ClientConnectionRunner?: IO exception sending I2CP message: java.io.IOException: Pipe closed
17:40:05.537 FEHLER [CP Writer 24] .client.ClientConnectionRunner?: IO exception sending I2CP message: java.io.IOException: Pipe closed
17:39:46.241 FEHLER [nt Writer 15] net.i2p.client.I2PSessionImpl2: [22686]: cause java.io.IOException: Pipe closed at java.io.PipedInputStream?.checkStateForReceive(Unknown Source) at java.io.PipedInputStream?.receive(Unknown Source) at java.io.PipedOutputStream?.write(Unknown Source) at net.i2p.data.DataHelper?.writeLong(DataHelper?.java:439) at net.i2p.data.i2cp.SendMessageMessage?.writeMessage(SendMessageMessage?.java:117) at net.i2p.client.ClientWriterRunner?.run(ClientWriterRunner?.java:69) at java.lang.Thread.run(Unknown Source) at net.i2p.util.I2PThread.run(I2PThread.java:77)
17:39:46.241 FEHLER [nt Writer 15] net.i2p.client.I2PSessionImpl2: [22686]: Error occurred: Error writing out the message - Pipe closed
17:13:07.322 FEHLER [acket pusher] ter.transport.udp.PacketPusher?: SSU Output Queue Error java.lang.IllegalStateException?: Already written at net.i2p.data.i2np.I2NPMessageImpl.verifyUnwritten(I2NPMessageImpl.java:356) at net.i2p.data.i2np.GarlicMessage?.writeMessageBody(GarlicMessage?.java:58) at net.i2p.data.i2np.I2NPMessageImpl.toByteArray(I2NPMessageImpl.java:232) at net.i2p.router.transport.ntcp.NTCPConnection.bufferedPrepare(NTCPConnection.java:672) at net.i2p.router.transport.ntcp.NTCPConnection.send(NTCPConnection.java:287) at net.i2p.router.transport.ntcp.NTCPTransport.outboundMessageReady(NTCPTransport.java:194) at net.i2p.router.transport.TransportImpl?.send(TransportImpl?.java:358) at net.i2p.router.transport.GetBidsJob?.getBids(GetBidsJob?.java:80) at net.i2p.router.transport.CommSystemFacadeImpl?.processMessage(CommSystemFacadeImpl?.java:134) at net.i2p.router.OutNetMessagePool?.add(OutNetMessagePool?.java:61) at net.i2p.router.transport.TransportImpl?.afterSend(TransportImpl?.java:253) at net.i2p.router.transport.TransportImpl?.afterSend(TransportImpl?.java:164) at net.i2p.router.transport.udp.UDPTransport.failed(UDPTransport.java:1396) at net.i2p.router.transport.udp.UDPTransport.failed(UDPTransport.java:1363) at net.i2p.router.transport.udp.PeerState?.finishMessages(PeerState?.java:1222) at net.i2p.router.transport.udp.OutboundMessageFragments?.finishMessages(OutboundMessageFragments?.java:222) at net.i2p.router.transport.udp.OutboundMessageFragments?.getNextVolley(OutboundMessageFragments?.java:246) at net.i2p.router.transport.udp.PacketPusher?.run(PacketPusher?.java:37) at java.lang.Thread.run(Unknown Source) at net.i2p.util.I2PThread.run(I2PThread.java:77)
16:52:11.709 KRITISCH [NTCP Pumper ] ter.transport.ntcp.EventPumper?: Error in the event pumper java.util.concurrent.RejectedExecutionException? at java.util.concurrent.ThreadPoolExecutor?$AbortPolicy?.rejectedExecution(Unknown Source) at java.util.concurrent.ThreadPoolExecutor?.reject(Unknown Source) at java.util.concurrent.ThreadPoolExecutor?.execute(Unknown Source) at net.i2p.router.transport.ntcp.NTCPSendFinisher.add(NTCPSendFinisher.java:50) at net.i2p.router.transport.ntcp.NTCPTransport.sendComplete(NTCPTransport.java:342) at net.i2p.router.transport.ntcp.NTCPConnection.removeWriteBuf(NTCPConnection.java:911) at net.i2p.router.transport.ntcp.EventPumper?.processWrite(EventPumper?.java:537) at net.i2p.router.transport.ntcp.EventPumper?.processKeys(EventPumper?.java:287) at net.i2p.router.transport.ntcp.EventPumper?.run(EventPumper?.java:131) at java.lang.Thread.run(Unknown Source) at net.i2p.util.I2PThread.run(I2PThread.java:77)
16:29:40.225 FEHLER [cheduler 2/4] net.i2p.util.ByteCache? : WARNING: Low memory, clearing byte caches

Subtickets

Change History (3)

comment:1 Changed 9 years ago by zzz

Component: api/datarouter/transport
Owner: set to zzz
Priority: majorminor
Status: newassigned
Summary: bugs bugs bugsNTCP RejectedExecution / Pipe Closed / SSU Output Queue Error

3 issues:

  • Pipe Closed is harmless, duplicate of many other tickets
  • SSU Output Queue Error a known bug, dup of other tickets

comment:2 Changed 9 years ago by zzz

Milestone: 0.8.3
Status: assignedaccepted
Version: 0.8.1

RejectedExecution? fixed in 0.8.1
Pipe closed changed from error to warn in 0.8.1-17
SSU error still to be dealt with

comment:3 Changed 9 years ago by zzz

Milestone: 0.8.30.8.2
Resolution: fixed
Status: acceptedclosed

Output Queue Error fixed in 0.8.1-22

Note: See TracTickets for help on using tickets.