Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#801 closed defect (fixed)

Vuze router integration broken in 0.9.3 - works in 0.9

Reported by: parg Owned by: zzz
Priority: major Milestone: 0.9.4
Component: api/i2cp Version: 0.9.3
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

The router integration used by the Vuze I2P plugin to establish connections is broken.

Here's a simple example that works on 0.9

final I2PSocketManager socket_manager = I2PSocketManagerFactory.createManager();

System.out.println( "got socket manager" );


I2PSession session = socket_manager.getSession();


System.out.println( "got session" );


final Destination my_dest = session.getMyDestination();


System.out.println( "got my dest" );

System.out.println( my_dest.toBase64());


new I2PThread()
{

public void
run()
{

while( true ){

try{

Thread.sleep( 1000 );


boolean res = socket_manager.ping( my_dest, 10*1000 );


System.out.println( "ping commplete: " + res);


}catch( Throwable e ){

e.printStackTrace();

}

}

}

}.start();

and fails with timeouts on 0.9.3 (i.e. the ping doesn't complete in 10 seconds). Connections to all other destinations also fail.

Subtickets

Change History (3)

comment:1 Changed 7 years ago by zzz

Component: unspecifiedapi/i2cp
Owner: set to zzz
Status: newaccepted

Apparently caused by ping bug ticket #799

comment:2 Changed 7 years ago by zzz

Priority: minormajor
Resolution: fixed
Status: acceptedclosed

Dup of #799 broken in 0.9.2 fixed in 0.9.3-13. Affected all external apps, not just Vuze, not just ping. Thanks for the report.

comment:3 Changed 7 years ago by zzz

0.9.4 works according to http://wiki.vuze.com/w/I2P_HowTo

Note: See TracTickets for help on using tickets.