Opened 7 years ago

Closed 7 years ago

#805 closed defect (fixed)

wrapper.config - log setting ignored by routerconsole/logs

Reported by: DISABLED Owned by:
Priority: minor Milestone: 0.9.5
Component: api/general Version: 0.9.3
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

The setting for the wrapper.log on my linux i2p is ignored by the page
http://host:7657/logs .
I changed the path for the logs for the wrapper.log to a seperate directory and it does well but the mentioned page still try to reload from "/tmp/wrapper.log"

Subtickets

Change History (6)

comment:1 Changed 7 years ago by killyourtv

What version of I2P is this?

How was it installed?

(In the meantime I'll check out the Debian package in case it's my bug.)

comment:2 Changed 7 years ago by zzz

Component: unspecifiedapps/console

Wrapper version? We should find the location for versions ≥ 3.3.7, that's when they added an API for it.

comment:3 Changed 7 years ago by DISABLED

  • What version of I2P is this?

Please include this information in bug reports:

I2P version: 0.9.3-0
Java version: Sun Microsystems Inc. 1.6.0_23 (Java™ SE Runtime Environment 1.6.0_23-b04)
Wrapper version: 3.1.1
Server version: 6.1.26
Servlet version: Jasper JSP 2.1 Engine
Platform: Linux i386 2.4.20-4GB (older Suse OS 8.2)
Processor: Pentium IV (130 nm) (pentium4)
Jbigi: Locally optimized native BigInteger? library loaded from file
Encoding: ISO-8859-15
Charset: ISO-8859-15

  • How was it installed?

I can't remember exactly … guess it was a headless package 7.x or early 8.x. Updates running automtically with the autoupdater.

hth

btw: Also the router.log ignoring every changes. A path changing over 'http://host:7657/configlogging' → "Configure I2P Logging Options
Log file: 'logs/log-router-@.txt'" to a static path is shown correctly for short in the console page -(including writing the 'router' logs to the new path)- but after 10 minuts or so .. it shows again the default-setting -('logs/log-router-@.txt')- and the writing of the logs changed again back to the relativ '/home/usr/.i2p/logs'.
A hard changing in the config-files AFTER stopping i2p, does/has the same effect. Shortly it takes the new path and after a while (~10 minuts) it switches back to the above-mentioned path.

I'd tried to change both config files, means does in the i2p installed path AND the users local-directory for i2p because I thought there is proberly a mix-up but.. after starting i2p it switches back to the default relativ-path-setting of the user and the config-files are changed back too. (Just to made it clear, I"P was not running when I changed the path in the config-files!)

Long text.. sry

comment:4 Changed 7 years ago by zzz

I'll try to reproduce your reported router log issue.

Please upgrade your wrapper http://www.i2p2.i2p/manualwrapper and confirm it fixes the problem reported in the OP, as I explained in comment 2 above.

comment:5 Changed 7 years ago by zzz

re: router log, there's a few things going on:

1) The setting in logger.config (default logger.logFileName=logs/log-@.txt) is overridden by the java command line set in wrapper.config wrapper.java.additional.1=-DloggerFilenameOverride?=logs/log-router-@.txt

2) Changing the file name on /configlogging does not change logger.config entry - looks like a bug

3) It gets changed back after a few minutes due to the periodic scanning of logger.config for changes

4) Changing the override setting in wrapper.config works for me

5) when you change it on /configlogging it says "Log file name pattern updated to logs/lig-router-@.txt (note: will not take effect until next rotation)" so it wasn't intended to take effect immmediately - it probably doesn't take effect at all though, since it gets changed back after a few minutes. Didn't test that though (I didn't wait for a rotation).

I guess the default is overridden by wrapper.config to change it from a app context name (log-@.txt) to a router context one, but it makes the java command line messy. There must be better ways to do it. It's always been that way, before my time.

Not sure how to reconcile which has priority, the system property (command line) or the logger.config setting, after it's changed on /configlogging.

comment:6 Changed 7 years ago by zzz

Component: apps/consoleapi/general
Milestone: 0.9.40.9.5
Resolution: fixed
Status: newclosed

Fixed in 0.9.4-4 b73141bfcba08cb78ca9c37cae6e35743d2d98f7

Use command line override only if config file has default.

Note: See TracTickets for help on using tickets.