Opened 7 years ago

Closed 7 years ago

#817 closed defect (fixed)

router.updateDisabled ignored

Reported by: killyourtv Owned by: zzz
Priority: major Milestone: 0.9.5
Component: router/update Version: 0.9.4
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

With router.updateDisabled=true set, the update to 0.9.4 was still downloaded.

Currently running 0.9.3-15 with a read-only $I2P.

Subtickets

Change History (4)

comment:1 Changed 7 years ago by zzz

Priority: minormajor

<zzz2> is that the setting you use for debs, or …?
<KillYourTV> yes
<zzz2> that's kindof a big problem then, no?
<zzz2> that will cause a lot of trouble at 0.9.5 time if we don't fix it before then?
<KillYourTV> I could do a special 'out-of-band' update just for the debian packages to fix this particular issue.
<KillYourTV> Basically, /configupdate shows that updates will happen via package upgrades. The sidebar shows Update downloaded <linebreak>Click Restart to install Version 0.9.4 and I see the i2pupdate.zip file is in the profile directory.
<KillYourTV> but….was it because I'm seeding the update in snark?
<zzz2> … not that I yet see where the bug is
<zzz2> good question

<zzz2> I assume you haven't restarted since eche updated the news?
<KillYourTV> no, i haven't.

<zzz2> seems like we'd want to fix it and do a PPA release asap, so most people don't update twice
<KillYourTV> there was a "download i2p 0.9.4" button and like a good/bad n00b I clicked it. The "Update Downloaded" text appeared almost instantly.
<zzz2> yeah the instant part is caused by you seeding
<KillYourTV> indeed
<zzz2> i put in a special check for that, heh.
<zzz2> but debs dont normally see a download button, right?
<zzz2> so this was a manual download? - the ticket implied automatic
<KillYourTV> sorry aobut that (even though no one's died). Normally the deb users will not see such download prompts.
<zzz2> ok I'm going to paste all this to the ticket and go looking for the problem. In the meantime start thinking about the mechanics of how to deliver a fix

comment:2 Changed 7 years ago by zzz

Owner: set to zzz
Status: newaccepted

0.9.3 NewsFetcher? had _updateAvailable = !dontInstall(); but that logic got lost on the way to 0.9.4.

comment:3 Changed 7 years ago by zzz

Should be fixed in 0d2f64f43335352d7dff797cd5d1bdacec3eb7f4. Leaving ticket open for testing.

comment:4 Changed 7 years ago by killyourtv

Resolution: fixed
Status: acceptedclosed

This seems to have resolved the issue.

Note: See TracTickets for help on using tickets.