Opened 6 years ago

Closed 6 years ago

#828 closed defect (duplicate)

Cannot change I2CP port on client side

Reported by: str4d Owned by: zzz
Priority: minor Milestone: 0.9.5
Component: api/i2cp Version: 0.9.4
Keywords: Cc:
Parent Tickets:

Description

I found this bug when trying to change the I2CP port that BOB-one.jar uses. I set i2cp.tcp.port=#### in bob.config (where #### is the local port of the SSH tunnel that is forwarding the I2CP port of the remote I2P router), but the I2CP client API only ever connects to port 7654. This was verified by changing the local port of the SSH tunnel to 7654 while leaving the config variable set to the original local port - BOB-one.jar is then able to successfully connect to the remote I2P router.

Subtickets

Change History (1)

comment:1 Changed 6 years ago by str4d

  • Resolution set to duplicate
  • Status changed from new to closed

Whoops, I got a "Bad Gateway Error" from the webserver and assumed the ticket hadn't been created. This is a duplicate of #827

Note: See TracTickets for help on using tickets.