Opened 6 years ago

Closed 6 years ago

#830 closed defect (not a bug)

High participating tunnel count in 0.9.4-3

Reported by: guest Owned by:
Priority: minor Milestone:
Component: unspecified Version: 0.9.4
Keywords: Cc:
Parent Tickets:

Description

The title may sound silly, but really the problem should be 'Low participating tunnel count in everything except 0.9.4-3'

I have a box up 24/7 running the latest dev builds of i2p. My network connection is close to the default so the only changes i have made to the setings is making th router console accessible remotely. In 0.9.4-2 and earlier i would usually be participating in 0,1,or 2 tunnels. The highest i ever saw was 10 participating. In 0.9.4-3 I suddenly was participating in around 70-90 tunnels, with the same default settings. Then from 0.9.4-4 I am back down to a much lower number (currently 8). The ports are opened correctly. The uptime since the upgrade to -4 is 26 hours so the router is well integrated.

I can provide logs or meet you on irc to answer any questions.

Subtickets

Change History (3)

comment:1 Changed 6 years ago by zzz

Participating tunnel count, especially for those on a low-speed router like yours, varies widely based on network conditions, the amount of available bandwidth on your connection and CPU on your PC, etc.

The network has huge variation based on time-of-day and day-of-week, and of course release-to-release.

High-speed routers with thousands of tunnels tend to see predictable patterns but you shouldn't expect the same.

Absent any other issue, it's nothing to worry about.

comment:2 Changed 6 years ago by str4d

  • Milestone 0.9.5 deleted

comment:3 Changed 6 years ago by zzz

  • Resolution set to not a bug
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.