Opened 7 years ago

Closed 7 years ago

#837 closed defect (fixed)

failed to execute runnablr

Reported by: Eche|on Owned by:
Priority: minor Milestone: 0.9.5
Component: apps/syndie Version: 0.9.4
Keywords: Cc:
Parent Tickets: Sensitive: no

Description (last modified by Eche|on)

Running Syndie Building version 1.101b-8 (mtn rev 733eefb03e647818cc13c4cc0a4659bbe20a7dc7)

Error:
Exception in thread "OutboundPusher1" org.eclipse.swt.SWTException: Failed to execute runnable (org.eclipse.swt.SWTException: Widget is disposed)

at org.eclipse.swt.SWT.error(SWT.java:4361)
at org.eclipse.swt.SWT.error(SWT.java:4276)
at org.eclipse.swt.widgets.Synchronizer.syncExec(Synchronizer.java:196)
at org.eclipse.swt.widgets.Display.syncExec(Display.java:4291)
at syndie.gui.Syndicator.archiveUpdated(Syndicator.java:1183)
at syndie.db.SyncArchive?.fireUpdated(SyncArchive?.java:161)
at syndie.db.SyncArchive?.fireUpdated(SyncArchive?.java:157)
at syndie.db.SyncArchive?.setIndexFetchInProgress(SyncArchive?.java:769)
at syndie.db.SyncArchive?.indexFetchFail(SyncArchive?.java:837)
at syndie.db.SyncOutboundPusher?$Runner.run(SyncOutboundPusher?.java:66)
at java.lang.Thread.run(Thread.java:722)

Caused by: org.eclipse.swt.SWTException: Widget is disposed

at org.eclipse.swt.SWT.error(SWT.java:4361)
at org.eclipse.swt.SWT.error(SWT.java:4276)
at org.eclipse.swt.SWT.error(SWT.java:4247)
at org.eclipse.swt.widgets.Widget.error(Widget.java:480)
at org.eclipse.swt.widgets.Widget.checkWidget(Widget.java:417)
at org.eclipse.swt.widgets.TreeItem?.setText(TreeItem?.java:1679)
at syndie.gui.Syndicator.locked_loadDataPush(Syndicator.java:983)
at syndie.gui.Syndicator.loadDataPush(Syndicator.java:914)
at syndie.gui.Syndicator.loadDataPushes(Syndicator.java:899)
at syndie.gui.Syndicator.loadData(Syndicator.java:658)
at syndie.gui.Syndicator.access$1200(Syndicator.java:46)
at syndie.gui.Syndicator$32.run(Syndicator.java:1183)
at org.eclipse.swt.widgets.RunnableLock?.run(RunnableLock?.java:35)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:135)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3529)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3182)
at syndie.gui.SWTUI.main(SWTUI.java:214)

And this one:

Exception in thread "OutboundPusher1" java.lang.NoSuchMethodError?: syndie.db.SyncArchive?$OutgoingAction?.getSize()I

at syndie.db.SyncOutboundPusher?.pushHTTP(SyncOutboundPusher?.java:402)
at syndie.db.SyncOutboundPusher?.push(SyncOutboundPusher?.java:120)
at syndie.db.SyncOutboundPusher?.access$400(SyncOutboundPusher?.java:27)
at syndie.db.SyncOutboundPusher?$Runner.run(SyncOutboundPusher?.java:63)
at java.lang.Thread.run(Thread.java:722)

Both on trying to sync.

echelon

Subtickets

Change History (4)

comment:1 Changed 7 years ago by Eche|on

Description: modified (diff)

comment:2 Changed 7 years ago by killyourtv

I think this was fixed in revision 597d556754a0574583b775fcaf557eeb0a0a6dc8. Please try updating to the latest revision.

Make sure you run "ant clean" before recompiling.

comment:3 Changed 7 years ago by zzz

Thanks for testing.

To avoid the 'ant clean' problem I've pushed improved dependency checking to the build.xml.

To avoid confusion, since 1.102b-1 has problems pushing and it appears to be fixed now, I've bumped the rev to 1.102b-2.

Please test -2 and report.

comment:4 Changed 7 years ago by Eche|on

Resolution: fixed
Status: newclosed

Moin

looks like -2 with mtn rev b28affb1cba056b553941cbabfb0b8362bd611c7 fixed the issue.
Great.

echelon

Note: See TracTickets for help on using tickets.