Opened 7 years ago

Closed 3 years ago

#839 closed defect (worksforme)

Syndie NPE during shutdown

Reported by: Zlatin Balevsky Owned by:
Priority: minor Milestone:
Component: apps/syndie Version: 0.9.4
Keywords: NPE hackfes Cc: zab@…
Parent Tickets: Sensitive: no

Description

No idea if this is normal or related to hsqldb :

     [java] Exception in thread "MsgFetcher 2" org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.NullPointerException)
     [java] 	at org.eclipse.swt.SWT.error(Unknown Source)
     [java] 	at org.eclipse.swt.SWT.error(Unknown Source)
     [java] 	at org.eclipse.swt.widgets.Synchronizer.syncExec(Unknown Source)
     [java] 	at org.eclipse.swt.widgets.Display.syncExec(Unknown Source)
     [java] 	at syndie.gui.Syndicator.incomingUpdated(Syndicator.java:1235)
     [java] 	at syndie.db.SyncArchive.notifyUpdate(SyncArchive.java:454)
     [java] 	at syndie.db.SyncArchive.access$000(SyncArchive.java:19)
     [java] 	at syndie.db.SyncArchive$IncomingAction.setSize(SyncArchive.java:238)
     [java] 	at syndie.db.SyncInboundFetcher$GetListener.bytesTransferred(SyncInboundFetcher.java:417)
     [java] 	at net.i2p.util.EepGet.doFetch(EepGet.java:686)
     [java] 	at net.i2p.util.EepGet.doFetch(EepGet.java:619)
     [java] 	at net.i2p.util.EepGet.fetch(EepGet.java:514)
     [java] 	at syndie.db.SyncInboundFetcher$Fetch.run(SyncInboundFetcher.java:365)
     [java] 	at java.lang.Thread.run(Thread.java:680)
     [java] Caused by: java.lang.NullPointerException
     [java] 	at org.hsqldb.Session.execute(Unknown Source)
     [java] 	at org.hsqldb.jdbc.jdbcPreparedStatement.<init>(Unknown Source)
     [java] 	at org.hsqldb.jdbc.jdbcConnection.prepareStatement(Unknown Source)
     [java] 	at syndie.db.DBClient.getChannelName(DBClient.java:1042)
     [java] 	at syndie.gui.Syndicator.locked_loadDataFetch(Syndicator.java:862)
     [java] 	at syndie.gui.Syndicator.loadDataFetch(Syndicator.java:784)
     [java] 	at syndie.gui.Syndicator.access$1800(Syndicator.java:51)
     [java] 	at syndie.gui.Syndicator$29.run(Syndicator.java:1235)
     [java] 	at org.eclipse.swt.widgets.RunnableLock.run(Unknown Source)
     [java] 	at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Unknown Source)
     [java] 	at org.eclipse.swt.widgets.Display.runAsyncMessages(Unknown Source)
     [java] 	at org.eclipse.swt.widgets.Display.readAndDispatch(Unknown Source)
     [java] 	at syndie.gui.SWTUI.main(SWTUI.java:214)

Subtickets

Change History (3)

comment:1 Changed 6 years ago by str4d

Keywords: NPE added

comment:2 Changed 4 years ago by str4d

Status: newopen

comment:3 Changed 3 years ago by zzz

Keywords: hackfes added; hackfest!!!! !!!11eleventy removed
Resolution: worksforme
Status: openclosed

Don't know but let's hope so.
There may be locking issues.
Just updated to HSQLDB 2.3.4, let's see how it goes.

Note: See TracTickets for help on using tickets.