Opened 6 years ago

Closed 6 years ago

#844 closed defect (fixed)

java.sql.SQLException: Violation of unique constraint $$:

Reported by: echelon Owned by: zzz
Priority: minor Milestone:
Component: apps/syndie Version: 0.9.4
Keywords: Cc:
Parent Tickets:

Description

Deleted the post Lbn7I3Dg0UvhHZQSX~vCvdsT0ThjHuf51YhnaaR21uQ=:1357941269686 from the database
Error importing the message
java.sql.SQLException: Violation of unique constraint $$: duplicate value(s) for column(s) $$: SYS_CT_79 in statement [INSERT INTO channelMessage (msgId, authorChannelId, messageId, targetChannelId, subject, overwriteScopeHash, overwriteMessageId, forceNewThread, refuseReplies, wasEncrypted, wasPrivate, wasAuthorized, wasAuthenticated, isCancelled, expiration, importDate, scopeChannelId, wasPBE, readKeyMissing, replyKeyMissing, pbePrompt, totalMessageSizeKB) VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, NOW(), ?, ?, ?, ?, ?, ?)]

at org.hsqldb.jdbc.Util.throwError(Unknown Source)
at org.hsqldb.jdbc.jdbcPreparedStatement.executeUpdate(Unknown Source)
at syndie.db.ImportPost?.insertToChannel(ImportPost?.java:772)
at syndie.db.ImportPost?.importMessage(ImportPost?.java:467)
at syndie.db.ImportPost?.process(ImportPost?.java:439)
at syndie.db.Importer.importPost(Importer.java:280)
at syndie.db.Importer.processMessage(Importer.java:197)
at syndie.db.SyndicateMenu?.importMsg(SyndicateMenu?.java:581)
at syndie.db.SyndicateMenu?.processBulkImport(SyndicateMenu?.java:558)
at syndie.db.SyndicateMenu?.processCommands(SyndicateMenu?.java:102)
at syndie.db.TextEngine?.processMenu(TextEngine?.java:491)
at syndie.db.TextEngine?.doRunStep(TextEngine?.java:145)
at syndie.db.TextEngine?.runStep(TextEngine?.java:127)
at syndie.db.TextEngine?.run(TextEngine?.java:116)
at syndie.db.TextUI.run(TextUI.java:288)
at syndie.db.TextUI.main(TextUI.java:234)

Post deleted from /opt/syndie/tmp/1358009785399.1950462461.imp/5.syndie
Post deleted from /opt/syndie/tmp/1358009785399.1950462461.imp/6.syndie

running -4

Subtickets

Change History (6)

comment:1 Changed 6 years ago by zzz

  • Milestone 0.9.5 deleted
  • Owner set to zzz
  • Status changed from new to accepted

Good timing. I'd seen this too. Turns out it was related to the password-protected posts issue (when you enter a password, it didn't work and threw out the same error).

Importing / reimporting of an existing message didn't work. The fix for the password case should work for this one too.

So hopefully fixed in 0b4a965df66081aac0b3a4f9fe90953a52f5d3b2 which is a couple of checkins after 1.102b-6.

comment:2 Changed 6 years ago by guest

  • Resolution set to worksforme
  • Status changed from accepted to closed

comment:3 Changed 6 years ago by str4d

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:4 Changed 6 years ago by guest

  • Resolution set to not a bug
  • Status changed from reopened to closed

comment:5 Changed 6 years ago by str4d

  • Resolution not a bug deleted
  • Status changed from closed to reopened

comment:6 Changed 6 years ago by zzz

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.