Opened 7 years ago

Closed 5 years ago

#850 closed defect (not a bug)

Version: 0.9.4-5 Network: ERR-Clock Skew of 41 sec

Reported by: Soap Owned by: zzz
Priority: minor Milestone:
Component: router/general Version: 0.9.4
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

Not seen with dev -4

Uptime 30 mins.
Network: ERR-Clock Skew of 41 sec

Reported clock skew seems to be erratic. PC synchronized to time server.
NTCP peers show either -47s or +47s skew, not much in between…

Subtickets

Change History (5)

comment:1 Changed 7 years ago by Soap

Not sure what happened here, clock skew now reported normal. Router behaving fine with good throughput.

Latest logs one after another..
8:16:35 PM ERROR [Timestamper ] net.i2p.util.Clock : Ignoring clock offset 1854ms (current -45263ms) since it would increase peer clock skew from -18478ms to 28639ms. Bad time server?
8:04:19 PM ERROR [Timestamper ] net.i2p.util.Clock : Ignoring clock offset 2070ms (current -45263ms) since it would increase peer clock skew from 11914ms to 59247ms. Bad time server?

Peer skew looks normal.

Will update.

comment:2 Changed 7 years ago by Soap

47 hours uptime all looks OK. TCP/UDB skew looks 'normal'
I think what happened is that my clock was off and this triggered the error. Subsequent synchronization resulted in the inverse polarity report.

Only issue to report then is 0.9.4-5 barfs at large (41s) clock skew on start.

comment:3 Changed 7 years ago by zzz

Component: router/netdbrouter/general

comment:4 Changed 7 years ago by str4d

Milestone: 0.9.5

comment:5 Changed 5 years ago by zzz

Resolution: not a bug
Status: newclosed
Note: See TracTickets for help on using tickets.