Opened 7 years ago

Closed 6 years ago

#853 closed defect (not a bug)

High number of DHT peers in i2psnark

Reported by: DISABLED Owned by: zzz
Priority: trivial Milestone:
Component: apps/i2psnark Version: 0.9.4
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

I2psnark reports an extremely high number of peers for the DHT. With most normal torrent clients I tend to have around 50 - 150 but with i2psnark i currently have 670. I don't know of any implications of this, hence the low priority, but I would still class it as abnormal behaviour.

Subtickets

Change History (4)

comment:1 Changed 7 years ago by zzz

What "normal torrent clients" ?

How many torrents do you have running?

comment:2 Changed 7 years ago by DISABLED

qBittorrent, µtorrent, transmission.

I have 20 torrents running in i2psnark

comment:3 Changed 7 years ago by zzz

OK thanks.

I don't know anything about those clients or how they count DHT peers.

The way i2psnark counts may be different. Maybe that's a clue that i2psnark should be changed to match the "normal" way to do it, whatever that is, or maybe it's due to differences in things like timeouts, DHT refresh strategies, etc. Snark has both a routing table and a node table, and iirc it's counting the node table, maybe others just use the routing table.

I followed the bittorrent DHT spec as closely as I could, but of course things like this aren't covered there.

Worth looking into further.

comment:4 Changed 6 years ago by zzz

Resolution: not a bug
Status: newclosed

Snark has a routing table and a node cache. It displays the size of the node cache which is larger than the routing table. Perhaps other clients display the routing table size. As I said above this isn't covered in the spec. I classify this as an implementation detail and not a bug.

Note: See TracTickets for help on using tickets.