Opened 6 years ago

Last modified 2 years ago

#857 reopened defect

Router console - Invalid form submission

Reported by: guest Owned by:
Priority: minor Milestone: undecided
Component: apps/console Version: 0.9.26
Keywords: form, submission, invalid, cookie Cc:
Parent Tickets:

Description

http://localhost:7657/graphs

While changing field "Periods" value from 60 to 120 and Clicking at "Save" I get:

Invalid form submission, probably because you used the 'back' or 'reload' button on your browser. Please resubmit. If the problem persists, verify that you have cookies enabled in your browser.

Core:
I2P version: 0.9.4-0-deb3l1
Java version: Oracle Corporation 1.7.0_11 (Java(TM) SE Runtime Environment 1.7.0_11-b21)
Wrapper version: 3.5.16
Server version: 6.1.26
Servlet version: Jasper JSP 2.1 Engine
Platform: Linux amd64 2.6.18-028stab101.1
Processor: Core i7 (32nm) (corei)
Jbigi: Locally optimized native BigInteger? library loaded from file
Encoding: UTF-8
Charset: UTF-8

Frontend:
Firefox & Chromium @ Ubuntu 12.10 64 bit

Thanks !

Subtickets (add)

Change History (10)

comment:1 Changed 6 years ago by zzz

  • Component changed from unspecified to apps/console

did you retry as the message suggests?
did you verify that you have cookies enabled as the message suggests?

comment:2 Changed 6 years ago by guest

Hi zzz,

yes i did. Also I tried with a new empty firefox profile.

Nobody else has this problem ?

BTW: From client to server I use a ssh tunnel for port 7657

Thanks.

comment:3 Changed 6 years ago by elgo

Hi,
I have this problem too with firefox.
Happens with or without ssh tunnel to the router console.
Do you have noscript plugin in firefox too (even if i2p console has been authorized in plugin, error happens)?

comment:4 Changed 6 years ago by guest

posting as another guest:

I can confirm this on linux/chromium-stable/i2p 0.9.4-7
seems to only happen with the graphing options submissions.

comment:5 Changed 6 years ago by guest

I can't reproduce it anymore. I'll keep this ticket updated if I see something useful.
I did tests with sun jvm 1.6 and openjdk 1.6: I don't get this message. As I remember I played a while with openjdk 1.7 too, I wonder if this version may be a parameter causing the issue.
Right now I can't restart my router with a 1.7, as I'm doing tests for another issue.

Worth trying if you can validate the JVM version, OP.

comment:6 Changed 6 years ago by killyourtv

I2P version: 0.9.4-11
Java 1.7.0_03-b21, 6b24-1.11.5-1, 1.5.0_05

FWIW I can also reproduce this on /graphs. Three different systems, and NO addons/tweaked settings. The new settings are applied even though

Invalid form submission, probably because you used the 'back' or 'reload' button on your browser. Please resubmit. If the problem persists, verify that you have cookies enabled in your browser.

is displayed at the top.

comment:7 Changed 6 years ago by guest

Hi killyourtv,

Thanks for your analysis. You are right: The new settings are applied.
But are not saved, if you click save. Every time you visits /graph its at 60s periods.

Thanks !

comment:8 Changed 6 years ago by zzz

  • Resolution set to fixed
  • Status changed from new to closed

Thanks for the report, reproduced here, fixed in b96598b8fddc1930c0857d99ef15fcc23d098f1c 0.9.4-12

comment:9 Changed 6 years ago by guest

Thanks, killyourtv + zzz

comment:10 Changed 2 years ago by xmz

  • Keywords form submission invalid cookie added
  • Milestone changed from 0.9.5 to undecided
  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Version changed from 0.9.4 to 0.9.26
Invalid form submission, probably because you used the 'back' or 'reload' button on your browser. Please resubmit. If the problem persists, verify that you have cookies enabled in your browser.

Okay, I still see these errors on 0.9.26. I started using I2P about 2 years ago and these errors have been commonplace for me.

My use case may be unusual so let me explain.
I have multiple routers which I manage over SSH port forwards (i.e. ssh -N -L 7777:127.0.0.1:7654 user@domain.net multiple times for local ports 7777 and onwards). It is common for me to make a configuration change on, say, 127.0.0.1:7778/configtunnels and then try to replicate that change on 127.0.0.1:7779/configtunnels. This causes the control panel at 127.0.0.1:7779/configtunnels to return the "Invalid Form Submission" error message without applying any of the changes that I attempted to save.

This is in

$ chromium --version
Chromium 52.0.2743.82 built on Debian stretch/sid, running on Debian stretch/sid

using incognito mode, no plugins are enabled for use in incognito mode.

What I usually have to do is to open the page 127.0.0.1:7779/configtunnels in a different browser, say Firefox and carry out the change there.

Note: See TracTickets for help on using tickets.