Opened 6 years ago

Last modified 3 years ago

#859 open enhancement

Cut down on I/O optionally on embedded devices

Reported by: dg Owned by:
Priority: minor Milestone:
Component: router/general Version: 0.9.4
Keywords: performance arm Cc: dg
Parent Tickets:

Description

Relevant forum post: http://zzz.i2p/posts/6172/
For embdedded devices, I/O can sometimes be resource-intensive and we should cut down on it where possible.
zzz mentions two main points, a heartbeat file and router info (NetDB) - the latter, IMO, is more useful as an enhancement but both could be beneficial.

Subtickets (add)

Change History (9)

comment:1 Changed 6 years ago by dg

To clarify, I/O can be intensive on small, embedded devices, was not referring to i2p.

comment:2 Changed 6 years ago by sponge

Don't forget the wear on flash.

comment:3 Changed 6 years ago by guest

  • Resolution set to not a bug
  • Status changed from new to closed

comment:4 Changed 6 years ago by killyourtv

  • Milestone changed from 0.9.5 to 0.9.8
  • Resolution not a bug deleted
  • Status changed from closed to reopened

Dunno who the mystery bug closer is but I think s/he shouldn't be closing bugs without logging in first.

Reopening.

comment:5 follow-up: Changed 6 years ago by zzz

You have a proposal on how to recognize an embedded device? Just assume anything with an ARM processor? Or???

comment:6 in reply to: ↑ 5 Changed 6 years ago by guest

Replying to zzz:

You have a proposal on how to recognize an embedded device? Just assume anything with an ARM processor? Or???

ARM processor/Android/advanced config option

comment:7 Changed 6 years ago by killyourtv

  • Status changed from reopened to new

comment:8 Changed 4 years ago by str4d

  • Keywords performance arm added
  • Milestone 0.9.8 deleted

comment:9 Changed 3 years ago by str4d

  • Status changed from new to open
Note: See TracTickets for help on using tickets.