Opened 6 years ago

Closed 6 years ago

#864 closed defect (worksforme)

i2p won't install as a service

Reported by: guest Owned by: killyourtv
Priority: minor Milestone:
Component: wrapper Version: 0.9.4
Keywords: Cc: killyourtv@…
Parent Tickets:

Description

On fedora 18, i tried to use sudo sh ~/i2p/i2prouter install having edited it to contain my login name, but i2p never starts on startup. there were no errors after instaling i2p as a service and i2p runs fine once started manually.

Subtickets

Change History (12)

comment:1 Changed 6 years ago by killyourtv

  • Cc killyourtv@… added
  • Owner set to killyourtv
  • Status changed from new to accepted

I'll try to get a fedora vm up so I can try fixing this.

comment:2 Changed 6 years ago by killyourtv

I should have asked: Which version of I2P is this and how long ago was it installed?

I just tried with a fresh installation of 0.9.4-10 and it worked fine. Perhaps your 'i2prouter' script doesn't have the necessary support ('i2prouter' is never updated outside of the Debian packages).

comment:3 Changed 6 years ago by guest

I got the 0.9.4 .jar from mirror.i2p2.de about a wek ago, and it hasn't worked since then. How could i fix this? Would this be enough? What will I lose if i do this?

rm -r ~/i2p/
java -jar i2pinstall_0.9.4.jar
vim ~/i2p/i2prouter
sh ~/i2p/i2prouter install

comment:4 Changed 6 years ago by killyourtv

  • Component changed from unspecified to wrapper

Hmm..0.9.4 should work fine. I don't know what the problem is but reinstalling won't fix it.

I'll investigating a bit more though it may take some time since I don't know my way around Fedora. I can say that with a fresh install of Fedora 18, "~/i2p/i2prouter install" as root worked fine. That is, I2P started when I rebooted my VM after running "i2prouter install".

comment:5 Changed 6 years ago by str4d

  • Milestone 0.9.5 deleted

comment:6 Changed 6 years ago by guest

  • Resolution set to wontfix
  • Status changed from accepted to closed

comment:7 Changed 6 years ago by str4d

  • Resolution wontfix deleted
  • Status changed from closed to reopened

Lack of response here does not indicate that we will not fix it, just that we don't have enough time or resources to do so right now (we only have a few developers).

comment:8 Changed 6 years ago by guest

  • Resolution set to worksforme
  • Status changed from reopened to closed

comment:9 Changed 6 years ago by str4d

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:10 Changed 6 years ago by guest

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:11 Changed 6 years ago by str4d

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:12 Changed 6 years ago by killyourtv

  • Resolution set to worksforme
  • Status changed from reopened to closed

Unfortunately I still have not been able to reproduce the failure. Pristine installations of Fedora 18 and I2P versions 0.9.4, 0.9.5, 0.9.6, 0.9.7, 0.9.8.x all work fine. It also works in Fedora 19.

Closing as 'worksforme'. If you can provide steps to reproduce this I'll be happy to investigate but at this time I don't see where there could be a problem.

Note: See TracTickets for help on using tickets.