Opened 7 years ago

Closed 6 years ago

#885 closed defect (fixed)

seedless not propperly removed

Reported by: DISABLED Owned by: sponge
Priority: minor Milestone: 0.9.13
Component: apps/plugins Version: 0.9.4
Keywords: seedless, plugin removal Cc:
Parent Tickets: Sensitive: no

Description

I2P version: 0.9.4-11
Java version: Sun Microsystems Inc. 1.6.0_26 (Java™ SE Runtime Environment 1.6.0_26-b03)
Wrapper version: 3.5.16
Server version: 6.1.26
Servlet version: Jasper JSP 2.1 Engine
Platform: Linux amd64 3.7.1-unixpool
Processor: Athlon 64 FX Opteron (athlon64)
Jbigi: Locally optimized native BigInteger? library loaded from file
Encoding: UTF-8
Charset: UTF-8

2/14/13 9:43:54 PM KRITISCH [.Main client] t.i2p.router.web.PluginStarter?: Error starting up the client class net.i2p.seedlesscoreclassincluder.Main

java.lang.reflect.InvocationTargetException?
at sun.reflect.NativeMethodAccessorImpl?.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl?.invoke(NativeMethodAccessorImpl?.java:39)
at sun.reflect.DelegatingMethodAccessorImpl?.invoke(DelegatingMethodAccessorImpl?.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at net.i2p.router.startup.LoadClientAppsJob?$RunApp?.run(LoadClientAppsJob?.java:261)
at java.lang.Thread.run(Thread.java:662)
at net.i2p.util.I2PThread.run(I2PThread.java:85)
Caused by: java.lang.ClassNotFoundException?: Can't Add SeedlessCore?, NeoDatis? not found.
at net.i2p.seedlesscoreclassincluder.Main.main(Main.java:140)
… 7 more

2/14/13 9:43:44 PM FEHLER [luginStarter] t.i2p.router.web.PluginStarter?: Failed to start plugin: 01_neodatis

java.lang.ClassNotFoundException?: net.i2p.neodatisclassincluder.Main
at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
at java.security.AccessController?.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at java.lang.ClassLoader?.loadClass(ClassLoader?.java:306)
at java.lang.ClassLoader?.loadClass(ClassLoader?.java:247)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:247)
at net.i2p.router.startup.LoadClientAppsJob?.testClient(LoadClientAppsJob?.java:149)
at net.i2p.router.web.PluginStarter?.runClientApps(PluginStarter?.java:663)
at net.i2p.router.web.PluginStarter?.startPlugin(PluginStarter?.java:290)
at net.i2p.router.web.PluginStarter?.startPlugins(PluginStarter?.java:188)
at net.i2p.router.web.PluginStarter?.run(PluginStarter?.java:75)
at java.lang.Thread.run(Thread.java:662)
at net.i2p.util.I2PThread.run(I2PThread.java:85)

2013/02/14 21:43:37 | Launching a JVM…
2013/02/14 21:43:37 | WrapperManager?: Initializing…
2013/02/14 21:43:37 | Starting I2P 0.9.4-11
2013/02/14 21:43:38 | INFO: Native CPUID library jcpuid-x86-linux loaded from file
2013/02/14 21:43:38 | INFO: Locally optimized native BigInteger? library loaded from file
2013/02/14 21:43:39 | INFO: Jetty 6.1.26 logging to I2P logs using class org.mortbay.jetty.Server
2013/02/14 21:43:44 | Adding /homes/undisclosed/.i2p/plugins/outertubes/lib/rabbit.jar to classpath for outertubes
2013/02/14 21:43:44 | Adding /homes/undisclosed/.i2p/plugins/outertubes/lib/rnio.jar to classpath for outertubes
2013/02/14 21:43:44 | Adding /homes/undisclosed/.i2p/plugins/outertubes/lib/dnsjava.jar to classpath for outertubes
2013/02/14 21:43:45 | Adding /homes/undisclosed/.i2p/plugins/i2pbote/lib/i2pbote.jar to classpath for i2pbote
2013/02/14 21:43:45 | Adding /homes/undisclosed/.i2p/plugins/i2pbote/lib/mailapi.jar to classpath for i2pbote
2013/02/14 21:43:45 | Adding /homes/undisclosed/.i2p/plugins/i2pbote/lib/bcprov-ecc-jdk16-146.jar to classpath for i2pbote
2013/02/14 21:43:45 | Adding /homes/undisclosed/.i2p/plugins/i2pbote/lib/flexi-gmss-1.7p1.jar to classpath for i2pbote
2013/02/14 21:43:45 | Adding /homes/undisclosed/.i2p/plugins/i2pbote/lib/ntruenc-1.2.jar to classpath for i2pbote
2013/02/14 21:43:45 | Adding /homes/undisclosed/.i2p/plugins/i2pbote/lib/scrypt-1.3.3.jar to classpath for i2pbote
2013/02/14 21:43:45 | Adding /homes/undisclosed/.i2p/plugins/i2pbote/lib/lzma-9.20.jar to classpath for i2pbote
2013/02/14 21:43:48 | INFO:BOB is now running.
2013/02/14 21:44:06 | KRITISCH [.Main client] t.i2p.router.web.PluginStarter?: Error starting up the client class net.i2p.seedlesscoreclassincluder.Main
2013/02/14 21:44:06 | java.lang.reflect.InvocationTargetException?
2013/02/14 21:44:06 | at sun.reflect.NativeMethodAccessorImpl?.invoke0(Native Method)
2013/02/14 21:44:06 | at sun.reflect.NativeMethodAccessorImpl?.invoke(NativeMethodAccessorImpl?.java:39)
2013/02/14 21:44:06 | at sun.reflect.DelegatingMethodAccessorImpl?.invoke(DelegatingMethodAccessorImpl?.java:25)
2013/02/14 21:44:06 | at java.lang.reflect.Method.invoke(Method.java:597)
2013/02/14 21:44:06 | at I had neodatis and seedless client running here. then i stopped and removed both plugins, restarted and get these errors:

net.i2p.router.startup.LoadClientAppsJob?$RunApp?.run(LoadClientAppsJob?.java:261)
2013/02/14 21:44:06 | at java.lang.Thread.run(Thread.java:662)
2013/02/14 21:44:06 | at net.i2p.util.I2PThread.run(I2PThread.java:85)
2013/02/14 21:44:06 | Caused by: java.lang.ClassNotFoundException?: Can't Add SeedlessCore?, NeoDatis? not found.
2013/02/14 21:44:06 | at net.i2p.seedlesscoreclassincluder.Main.main(Main.java:140)
2013/02/14 21:44:06 | … 7 more

Subtickets

Change History (4)

comment:1 Changed 7 years ago by DISABLED

I had neodatis and seedless client running here. then i stopped and removed both plugins, restarted and get these errors.
both directories stil present:
~/.i2p/plugins$ ls
01_neodatis 02_seedless …

comment:2 Changed 7 years ago by zzz

Owner: set to sponge
Status: newassigned

Were there any files left in the directories or were they empty? Please list the files if there are any.

Last I looked, the seedless/neodatis plugins incorrectly installed files directly in ~.i2p, which will not be removed either.

comment:3 Changed 7 years ago by str4d

Milestone: 0.9.5

comment:4 Changed 6 years ago by zzz

Milestone: 0.9.13
Resolution: fixed
Status: assignedclosed

Possibly related to #1257 fixed in 0.9.13. This ticket is very old and we never got a response from the OP. Optimistically closing as fixed.

Note: See TracTickets for help on using tickets.