Opened 7 years ago

Closed 6 years ago

#907 closed defect (no response)

i2psnark does not recognize any torrents when invoked with autoStart=true

Reported by: wolkenzorn Owned by: zzz
Priority: minor Milestone: 0.9.6
Component: apps/i2psnark Version: 0.9.4
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

With i2snark.autoStart=true, no torrents at all are displayed in the i2psnark web console, even though there should 4 be present. (This is the problem.)

With i2snark.autoStart=false, all 4 get displayed but need to be started manually.

i2p 0.9.5 under Linux x64, running official jdk-1.6.0.43.

Problem started to occur after changing "Launch browser on router startup?" to "Do not view console".

Reproducible: Always.

No idea how to check for errors when nothing is displayed.

Subtickets

Change History (5)

comment:1 Changed 7 years ago by DISABLED

When Snark is set to autostart torrents (recommended), any pre-existing torrents will not appear in the main view until the startup delay time has passed. This is a feature. Dial down the startup delay if you wish to see your torrents appear sooner!

comment:2 Changed 7 years ago by killyourtv

Resolution: not a bug
Status: newclosed

OP: I think you're misunderstanding how it works. When i2psnark is set to autostart, torrents will not be added until 3 minutes have elapsed. You can see this in
apps/i2psnark/java/src/org/klomp/snark/SnarkManager.java

public static final int DEFAULT_STARTUP_DELAY = 3;

comment:3 Changed 7 years ago by wolkenzorn

Resolution: not a bug
Status: closedreopened

Hm, no. Let's tell me like that:

Variant a) Torrents on auto-start. After the 3 minute delay, the list remains empty. Always. None are displayed even if there are a number of torrents in the associated directory.

Variant b) Torrents are NOT on auto-start. The torrents in the directory are being displayed. You can start them manually and everything works.

As I found out, one of the torrents present in the directory apparently led to a crash when auto-started, making the resulting list appear empty. After removing that one, i2psnark works again like I think it should.

comment:4 Changed 7 years ago by zzz

Milestone: 0.9.50.9.6

Please provide information and logs about the bad torrent causing a crash. That shouldn't happen.

comment:5 Changed 6 years ago by zzz

Resolution: no response
Status: reopenedclosed

Please reopen if you have more information about the bad torrent.

Note: See TracTickets for help on using tickets.