Opened 6 years ago

Closed 6 years ago

#909 closed defect (invalid)

I2P router listen only IPv6 on IPv4-Ipv6 dual-stack computers

Reported by: DISABLED Owned by:
Priority: minor Milestone: 0.9.5
Component: router/transport Version: 0.9.4
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

I have dual-stack on my computer (IPv4 and IPv6).

Unfortunately, i2p router opens listening ports only on IPv6. And I can't utilize my internet channel by i2p as I wish, because transit traffic very low.

Subtickets

Change History (3)

comment:1 Changed 6 years ago by killyourtv

Are you trying to use "localhost" or "127.0.0.1"? You'd be better off using "127.0.0.1" because some OSes default to pointing localhost to ::1. If you look on http://127.0.0.1:7657/i2ptunnel/ you'll see that the tunnels are bound to IPv4.

I recommend using Tor as an outproxy to the Internet. I2P is intended to be an *internal* network.

comment:2 Changed 6 years ago by DISABLED

No, I don't talk about listening ports on localhost/127.0.0.1.

I talk about ports for peers.

#netstat -tulnp | grep 3120

tcp        0      0 127.0.0.1:32000         0.0.0.0:*               LISTEN      3120/java           
tcp6       0      0 127.0.0.1:7654          :::*                    LISTEN      3120/java           
tcp6       0      0 127.0.0.1:7657          :::*                    LISTEN      3120/java           
tcp6       0      0 ::1:7657                :::*                    LISTEN      3120/java           
tcp6       0      0 127.0.0.1:7658          :::*                    LISTEN      3120/java           
tcp6       0      0 127.0.0.1:7659          :::*                    LISTEN      3120/java           
tcp6       0      0 127.0.0.1:7660          :::*                    LISTEN      3120/java           
tcp6       0      0 127.0.0.1:6668          :::*                    LISTEN      3120/java           
tcp6       0      0 127.0.0.1:4444          :::*                    LISTEN      3120/java           
tcp6       0      0 127.0.0.1:4445          :::*                    LISTEN      3120/java           
tcp6       0      0 :::15822                :::*                    LISTEN      3120/java           
udp6       0      0 :::15822                :::*                                3120/java

as you can see, process 3120/java (i2p) listnen ports for other peers only on IPv6:

tcp6       0      0 :::15822                :::*                    LISTEN      3120/java           
udp6       0      0 :::15822                :::*                                3120/java

so, IPv4 peers can't connect to my router, only through IPv6

comment:3 Changed 6 years ago by killyourtv

Component: unspecifiedrouter/transport
Resolution: invalid
Status: newclosed

Thanks for the follow-up.

What you've reported here is normal and is not a bug in I2P. For whatever reason Java apps are always displayed for me in netstat and lsof output as TCP6 even if they only communicate via IPv4.

No clients will connect to your I2P router via IPv6 because I2P doesn't "speak" IPv6. The support has to be added. See http://zzz.i2p/posts/6273/topic for more info.

I'll close this ticket as it's not a bug: I2P is not listening on IPv6 because it can't, but it should hopefully learn IPv6 in the near future.

Note: See TracTickets for help on using tickets.